Bug 1274904 - [abrt] plasma-workspace: KCrash::defaultCrashHandler(): plasmashell killed by SIGSEGV
[abrt] plasma-workspace: KCrash::defaultCrashHandler(): plasmashell killed by...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plasma-workspace (Show other bugs)
23
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
AcceptedBlocker abrt_hash:4f75ddde3a0...
:
: 1276495 (view as bug list)
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-10-23 15:34 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-31 12:05 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 12:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.77 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: cgroup (177 bytes, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: core_backtrace (55.81 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: dso_list (30.24 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: environ (1.55 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: maps (85.01 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: mountinfo (2.95 KB, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: open_fds (187 bytes, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
File: proc_pid_status (875 bytes, text/plain)
2015-10-23 15:34 EDT, Giulio 'juliuxpigface'
no flags Details
.xsession-errors from a reproduction (46.49 KB, text/plain)
2015-10-23 19:14 EDT, Adam Williamson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 352454 None None None Never

  None (edit)
Description Giulio 'juliuxpigface' 2015-10-23 15:34:02 EDT
Description of problem:
It happened on a live session of KDE i686 {RC3 compose}.
The exact moment of the crash, lies between the autologin of 'liveuser' and the manual launch of the application 'gnome-abrt'.

I don't know if this is reproducible: I'll try to reproduce it as soon as possible.

Version-Release number of selected component:
plasma-workspace-5.4.2-4.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler
executable:     /usr/bin/plasmashell
global_pid:     1642
kernel:         4.2.3-300.fc23.i686
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 KCrash::defaultCrashHandler at ../../src/kcrash.cpp:409
 #4 mdb_reader_check at mdb.c:9374
 #5 Baloo::Database::open at ../../../src/engine/database.cpp:82
 #6 Baloo::SearchStore::SearchStore at ../../../src/lib/searchstore.cpp:51
 #7 Baloo::Query::exec at ../../../src/lib/query.cpp:209
 #8 SearchRunner::match at ../../../runners/baloo/baloosearchrunner.cpp:98
 #10 Plasma::AbstractRunner::performMatch at ../../src/abstractrunner.cpp:131
 #11 Plasma::FindMatchesJob::run at ../../src/runnerjobs.cpp:159
 #12 ThreadWeaver::Executor::run at ../../src/executor.cpp:52
 #13 ThreadWeaver::Private::DefaultExecutor::execute at ../../src/job_p.cpp:70
Comment 1 Giulio 'juliuxpigface' 2015-10-23 15:34:10 EDT
Created attachment 1085904 [details]
File: backtrace
Comment 2 Giulio 'juliuxpigface' 2015-10-23 15:34:12 EDT
Created attachment 1085906 [details]
File: cgroup
Comment 3 Giulio 'juliuxpigface' 2015-10-23 15:34:15 EDT
Created attachment 1085907 [details]
File: core_backtrace
Comment 4 Giulio 'juliuxpigface' 2015-10-23 15:34:18 EDT
Created attachment 1085908 [details]
File: dso_list
Comment 5 Giulio 'juliuxpigface' 2015-10-23 15:34:20 EDT
Created attachment 1085909 [details]
File: environ
Comment 6 Giulio 'juliuxpigface' 2015-10-23 15:34:22 EDT
Created attachment 1085910 [details]
File: limits
Comment 7 Giulio 'juliuxpigface' 2015-10-23 15:34:27 EDT
Created attachment 1085911 [details]
File: maps
Comment 8 Giulio 'juliuxpigface' 2015-10-23 15:34:29 EDT
Created attachment 1085912 [details]
File: mountinfo
Comment 9 Giulio 'juliuxpigface' 2015-10-23 15:34:31 EDT
Created attachment 1085913 [details]
File: open_fds
Comment 10 Giulio 'juliuxpigface' 2015-10-23 15:34:33 EDT
Created attachment 1085914 [details]
File: proc_pid_status
Comment 11 Adam Williamson 2015-10-23 16:03:33 EDT
If you were running the 'launch all applications' test, note it's best to do that after install, not when running live; live sessions are kinda intrinsically subject to running out of RAM at some point, at which point all kinds of weird stuff starts happening.

If you just booted live then ran gnome-abrt, that could be problematic indeed. I'll see if I can reproduce.
Comment 12 Rex Dieter 2015-10-23 16:12:04 EDT
Hrm... baloo service shouldn't even be running on live...
Comment 13 Giulio 'juliuxpigface' 2015-10-23 16:27:08 EDT
I forgot to mention that I'm testing with qemu-kvm.

(In reply to awilliam@redhat.com from comment #11)
> If you just booted live then ran gnome-abrt, that could be problematic
> indeed. I'll see if I can reproduce.

I've just launched gnome-abrt right after the boot. The issue seems reproducible only in a live environment: I haven't hit on the installed system yet.
Comment 14 Adam Williamson 2015-10-23 18:55:46 EDT
Another user experienced a similar problem:

Booted F23 Final RC3 KDE i686 live, waited a bit, ran Konqueror from the kicker. The shell crashed then respawned itself, and this notification appeared.

reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler
executable:     /usr/bin/plasmashell
global_pid:     1657
kernel:         4.2.3-300.fc23.i686
package:        plasma-workspace-5.4.2-4.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Adam Williamson 2015-10-23 18:57:21 EDT
Hmm, so yeah, I hit the same crash, only running a different app.

`ps aux | grep aloo` on the live image shows `/bin/akonadi_baloo_indexer --identifier akonadi_baloo_indexer` running.
Comment 16 Adam Williamson 2015-10-23 19:13:27 EDT
I actually think just opening the Kicker is enough to trigger this one, it happened to me again. Well, I think it was the same thing, this time the shell never came back so I was just stuck with a console. I'm gonna attach ~/.xsession-errors from that crash.
Comment 17 Adam Williamson 2015-10-23 19:14 EDT
Created attachment 1085972 [details]
.xsession-errors from a reproduction
Comment 18 Adam Williamson 2015-10-23 19:17:27 EDT
I'm proposing this as a blocker. It seems fairly trivially reproducible: just boot a 32-bit KDE live image, open the Kicker, and type a couple of characters. Seems to cause the crash every time.

There's a criteria problem here because all our desktop functionality requirements are technically for *post-install*, but I'll cite:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."

and say that I reckon at least some of the desktop functionality requirements should apply to the live environment as well as the installed environment.
Comment 19 Bruno Wolff III 2015-10-24 12:27:07 EDT
+1 blocker.
(We are still blocking on i686 for f23 right?)
Comment 20 Adam Williamson 2015-10-24 16:53:05 EDT
Yup.
Comment 21 Rex Dieter 2015-10-26 12:29:41 EDT
I have a suspicion this *may* be fixed with lmdb-0.9.16-1.fc23,
http://koji.fedoraproject.org/koji/buildinfo?buildID=677308

which was built, but never submitted as an update.

I'll try testing myself with a i686/32bit setup at first opportunity, but I'd encourage anyone else to try lmdb-0.9.16-1.fc23 to see if that helps.
Comment 22 Fedora Update System 2015-10-26 12:33:59 EDT
lmdb-0.9.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-25d6622b7d
Comment 23 Petr Schindler 2015-10-26 13:30:54 EDT
Discussed at 2015-10-26 blocker review meeting: [1]. 

This bug was accepted as Final blocker: This bug is a clear violation of the following criterion: "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2015-10-26/f23-blocker-review.2015-10-26-16.00.html
Comment 24 Adam Williamson 2015-10-26 14:43:43 EDT
The lmdb update does appear to fix this in at least one test, yep. I'm running into another issue in testing, will double-confirm later.
Comment 25 Adam Williamson 2015-10-26 15:20:18 EDT
Yeah, the fix works.
Comment 26 Fedora Update System 2015-10-26 22:20:31 EDT
lmdb-0.9.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update lmdb'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-25d6622b7d
Comment 27 Adam Williamson 2015-10-27 15:41:18 EDT
Oh, damn - yes, I see this in RC5 too.

I think I may have tested this wrong before: I somehow got mixed up and thought the crash happened on *installed* systems, when in fact it happens running live. So I tested after install and didn't see the crash :( My bad.
Comment 28 Adam Williamson 2015-10-27 17:09:02 EDT
FWIW, I built an image with the kickstart bit that disables the Baloo indexer commented out, and that makes the bug go away. The bug doesn't happen post-install (another case where the indexer would run), and it doesn't happen on x86_64. So, it looks like the bug happens only on 32-bit, and only when the Baloo indexer didn't run (so presumably some database or other that it goes to look in is empty or not there or similar).
Comment 29 Fedora Update System 2015-10-27 17:56:35 EDT
kf5-baloo-5.14.0-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3093b24027
Comment 30 Adam Williamson 2015-10-27 18:17:03 EDT
That one really *does* seem to fix the bug. I'm like nearly certain I tested it right this time! :)
Comment 31 Adam Williamson 2015-10-27 18:39:15 EDT
I also confirmed the issue is still fixed if I drop lmdb back to 0.9.14-2 - we really only need the baloo patch to fix this, not the updated lmdb.
Comment 32 Jan Sedlák 2015-10-29 10:50:36 EDT
Looks like it's fixed in RC6 with kf5-baloo-5.14.0-3.fc23.
Comment 33 Rex Dieter 2015-10-29 16:59:05 EDT
*** Bug 1276495 has been marked as a duplicate of this bug. ***
Comment 34 Fedora Update System 2015-10-31 12:05:01 EDT
kf5-baloo-5.14.0-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.