Bug 1274922 - Start using OFD locks
Start using OFD locks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
24
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Robbie Harwood
Fedora Extras Quality Assurance
https://github.com/krb5/krb5/pull/512
:
Depends On: 1264556
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 17:07 EDT by Robbie Harwood
Modified: 2016-08-15 13:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: krb5-1.14.3-5.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-15 13:46:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robbie Harwood 2015-10-23 17:07:19 EDT
Switching over to OFD locks (which is desirable where possible due to superior concurrency management) has been delayed due to causing the test suite to hang (deadlock - possibly a libc issue) on i686.  Since we would like to be using these going forward, this needs to be resolved, though for the moment we can continue to progress using old-style locking.
Comment 1 Jan Kurik 2016-02-24 08:52:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.