Bug 1274928 - Incorrect proxy from node to Apache [NEEDINFO]
Incorrect proxy from node to Apache
Status: CLOSED INSUFFICIENT_DATA
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miciah Dashiel Butler Masters
chaoyang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 18:19 EDT by Dmitry Tsvettsikh
Modified: 2016-01-29 16:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 16:19:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mmasters: needinfo? (dmitrycvet)


Attachments (Terms of Use)

  None (edit)
Description Dmitry Tsvettsikh 2015-10-23 18:19:27 EDT
Description of problem:
Apache incorrect proxied response from my node server. When I login to my gear throuth ssh and use wget, then i get response directly from my app. And response status code is 200. But Apache return 404. The problem started after pushing the new version.

Example request with bug: http://torrenteditor-rmapps.rhcloud.com/api/torrent/3F4997E5EB2C8DAA4C97D65DF280F8E58B7A2C91/udp%3A%2F%2Fglotorrents.pw%3A6969%2Fannounce

Apache incorrect headers:

HTTP/1.1 404 Not Found
Date: Fri, 23 Oct 2015 22:04:24 GMT
Server: Apache/2.2.15 (Red Hat)
Content-Length: 384
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

Correct headers from app
HTTP/1.1 200 OK
Content-Type: application/json
Content-Length: 85
Date: Fri, 23 Oct 2015 22:09:56 GMT
Connection: keep-alive

Version-Release number of selected component (if applicable):
Node v4.2.1

How reproducible:
I don`t known how to reproduce...

Actual results:
Status code 404.

Expected results:
Status code 200.

Additional info:
Repo https://github.com/ReklatsMasters/torrent-editor/tree/50771677cbb7f1f30ee7ee29d86550d2b30120db
Comment 1 Miciah Dashiel Butler Masters 2015-12-01 16:00:24 EST
I tried the following steps to reproduce the problem:

1. Download a .torrent file to the local system—I used the following: http://burnbit.com/download/354912/SL_7_1_x86_64_netinst_iso

2. Create an application on OpenShift Online from the GitHub repository: `rhc app create testtorrenteditor nodejs --from-code=https://github.com/ReklatsMasters/torrent-editor.git`.

3. Browse to the new application on OpenShift Online, click "choose torrent", and select the .torrent file from Step 1.

4. Select the URL, open a new tab, and browse to the URL in the new tab.

5. SSH to the application's gear: `rhc ssh testtorrenteditor`.

6. Curl the URL from Steps 3 and 4.

7. Curl the local gear (`curl -v http://${OPENSHIFT_NODEJS_IP}:${OPENSHIFT_NODEJS_PORT}/api/torrent/666EEFA9C61C84F70AF5FD2C8B9876EF36BDA62C`).


At Step 3, the editor comes up with the correct data from the .torrent file.  Everything looks fine.

At Step 4, I get a 404 (and the browser is redirected to /torrent-not-found).

At Steps 6 and 7, I still get a 404.

I believe you are saying that Step 7 should not return a 404; am I correct? Are you following the same steps that I listed above and seeing a 200 at Step 7?
Comment 2 Miciah Dashiel Butler Masters 2016-01-12 16:19:53 EST
Hi, Dmitry! Have you been able to look into the issue further in order to answer the questions in comment 1? We need more information in order to be able to reproduce the problem and fix it.  Thanks!
Comment 3 Rory Thrasher 2016-01-29 16:19:14 EST
Closing for lack of reporter response.  Please feel free to reopen with requested information if the problem still persists.

Note You need to log in before you can comment on or make changes to this bug.