Bug 1274947 - dnf update of kf5 components triggers bug-report wizards
dnf update of kf5 components triggers bug-report wizards
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kf5-kservice (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 20:53 EDT by George R. Goffe
Modified: 2016-06-07 12:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-07 10:50:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar.gz of 3 log files related to this bug (19.33 KB, application/x-gzip)
2015-10-23 20:53 EDT, George R. Goffe
no flags Details

  None (edit)
Description George R. Goffe 2015-10-23 20:53:38 EDT
Created attachment 1086039 [details]
tar.gz of 3 log files related to this bug

Description of problem:

Running dnf -y upgrade caused two bug report wizards to appear. The first, for kf5init(?) says there's no debug address to send the report to. Subsequent entry to debug asks for debuginfo which also fails. I don't know how reproducible these failures are since the first upgrade succeeded. I'm attaching both logs to this bug in the hope that they'll be of some use.

Version-Release number of selected component (if applicable):

see the logs, more than one component involved

How reproducible:

unknown

Steps to Reproduce:
1.dnf -y upgrade
2.poke debug on first wizard popup
3.gdb asks for debuginfo-install which fails

Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2015-10-24 19:17:40 EDT
For the -debuginfo file conflict, just remove the older -debuginfo package.

For the KService crash, I guess this is just due to files changing under it during the upgrade, not sure whether it's fixable. If it doesn't happen again after restarting your session with the updates packages, just ignore the crash.
Comment 2 Rex Dieter 2016-06-07 10:50:50 EDT
Per comment #1 , and lack of more reports of this happening, will consider as WONTFIX (for now)
Comment 3 George R. Goffe 2016-06-07 12:08:29 EDT
Rex,

I'm ok with closing this one. I WILL be watching for any recurrence and report that after trying the above suggestions.

THANKS,

George...

Note You need to log in before you can comment on or make changes to this bug.