Bug 1274990 - Enable lookup-optimize for tiered volumes
Enable lookup-optimize for tiered volumes
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-24 11:38 EDT by Dan Lambright
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-25 10:23:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-10-24 11:38:44 EDT
The lookup-optimize is an important DHT optimization. Rather than sending lookups to all sub volumes, it only sends lookups to hashed sub volumes (unless there has been a configuration change). Tiered volumes can benefit from the feature in lower level DHT translators.
Comment 1 Vijay Bellur 2015-10-24 11:54:40 EDT
REVIEW: http://review.gluster.org/12421 (cluster/tier: WIP support lookup-optimize for tiered volumes) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Dan Lambright 2015-10-25 10:23:10 EDT
I don't think it is needed based on experiments and code inspection: I think this is because it is only included if the voltype is "cluster/distribute" per glusterd-volume-set whereas tier uses cluster/tier. I created distributed volume with lookup-unhashed on, then attached tier. Also set lookup-unhashed to an existing volume, turned the volume off then back on. In all cases the dict reaching tier_init() did not include lookup-unhashed.

Setting to CLOSED and will reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.