Bug 1275092 - No Menu with XFT - Example VB
No Menu with XFT - Example VB
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Prima (Show other bugs)
22
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 16:22 EDT by rue.wessel
Modified: 2015-11-11 00:53 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Prima-1.42-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 00:53:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of VB without displaying fonts (5.12 KB, image/png)
2015-10-25 16:22 EDT, rue.wessel
no flags Details

  None (edit)
Description rue.wessel 2015-10-25 16:22:41 EDT
Created attachment 1086285 [details]
Screenshot of VB without displaying fonts

Description of problem:

No fonts displayed using default option xft.
Problem appears with visual builder VB but also in own scripts using prima


Version-Release number of selected component (if applicable):
perl-Prima.x86_64                      1.42-2.fc22                       @fedora

How reproducible:
Execute /bin/VB after fresh install Fedora 22

Steps to Reproduce:
1.Install Fedora 22
2.Install package perl-Prima
3. Start /bin/VB

Actual results:
No fonts in menues displayed

Expected results:
Menues displayed as starte

Additional info:
Menues will display if started as VB --no-xft
or 
VB --font-priority='core'
Comment 1 Petr Pisar 2015-10-26 06:07:00 EDT
I have no idea what /bin/VB is. It looks like not delivered by the Fedora. Maybe you don't have the proper font installed. Try to install liberation-sans-fonts package. I cannot help if I cannot reproduce the problem if I don't have /bin/VB on my system.
Comment 2 rue.wessel 2015-10-27 12:28:03 EDT
(In reply to Petr Pisar from comment #1)
> I have no idea what /bin/VB is. It looks like not delivered by the Fedora.
> Maybe you don't have the proper font installed. Try to install
> liberation-sans-fonts package. I cannot help if I cannot reproduce the
> problem if I don't have /bin/VB on my system.

Dear Petr,

/bin/VB is part of perl-Prima. It is the visual builder which comes
with Prima. 

liberation-sans-fonts-1:1.07.4-6.fc22.noarch is already installed at
both systems I have tested.
Comment 3 Petr Pisar 2015-10-27 12:58:04 EDT
I see. It's /usr/bin/VB.

I can reproduce the issue. It looks like something has changed in freetype or fontconfig libraries causing the rendering issues. Prima-1.43 changed how the XFT fonts are handled and does not suffer from this problem.

I will look if it's possible to port the fix to Fedora 22's Prima-1.42 or if it feasible to rebase the package completely.
Comment 4 Petr Pisar 2015-10-27 13:46:30 EDT
Upstream fixed it with

commit 6695af5aa870c94e17fdd36a01e9fda513597567
Author: Dmitry Karasik <dmka@novozymes.com>
Date:   Tue Mar 31 17:22:50 2015 +0200

    rehaul of xft for testing of corner cases

Changelog does not mention any incompatibilities, but for example the Prima/CORE/img.h changed ABI of struct _ImgIORequest between 1.42 and 1.43.
Comment 5 Petr Pisar 2015-10-27 14:13:19 EDT
I ported the patch. I wish it fixed the issue for you without any regressions. I will submit the package into updates-testing repository for testing. If problems appears there, I will rebase the package.
Comment 6 Fedora Update System 2015-10-27 16:00:19 EDT
perl-Prima-1.42-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-e2d71bfbf0
Comment 7 Fedora Update System 2015-11-01 19:28:07 EST
perl-Prima-1.42-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-Prima'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-e2d71bfbf0
Comment 8 Fedora Update System 2015-11-11 00:53:02 EST
perl-Prima-1.42-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.