Bug 1275096 - Can't load the cadastre.fr plugin
Can't load the cadastre.fr plugin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: josm (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cédric OLIVIER
Fedora Extras Quality Assurance
:
Depends On: 1236705
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 17:17 EDT by Ludovic Hirlimann
Modified: 2016-02-26 02:22 EST (History)
2 users (show)

See Also:
Fixed In Version: josm-0-0.74.9329svn.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 02:22:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ludovic Hirlimann 2015-10-25 17:17:42 EDT
Description of problem:

Install the cadastre for french user and restart to load the plugin - it fails with a stack trace.

Version-Release number of selected component (if applicable):

fedora22 and the old josm bundled with it.

How reproducible:

launch josm, preferences -> plugins -> sleect frenc cadastre restart.


Actual results:

[ludo@Oulanl ~]$ ERROR: Failed to locate image 'styles/standard/shop/rental/library.png'
WARNING: Could not get presets icon styles/standard/shop/rental/library.png
INFO: loading plugin 'jts' (version 31603)
INFO: loading plugin 'geotools' (version 31603)
INFO: loading plugin 'cadastre-fr' (version 31665)
INFO: Pluging cadastre-fr v2.6 started...
INFO: current cache directory: /home/ludo/.josm/cache/cadastrewms/
INFO: Replace source year AAAA by current year 2015
ERROR: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin cadastre-fr. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.MainMenu.addMenu(Ljava/lang/String;Ljava/lang/String;IILjava/lang/String;)Ljavax/swing/JMenu;
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin cadastre-fr
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:331)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:589)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:651)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:691)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:432)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:422)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:328)
	... 4 more
Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.MainMenu.addMenu(Ljava/lang/String;Ljava/lang/String;IILjava/lang/String;)Ljavax/swing/JMenu;
	at cadastre_fr.CadastrePlugin.refreshMenu(CadastrePlugin.java:221)
	at cadastre_fr.CadastrePlugin.refreshConfiguration(CadastrePlugin.java:284)
	at cadastre_fr.CadastrePlugin.<init>(CadastrePlugin.java:209)
	... 9 more
INFO: Message notifier active (checks every 5 minutes)
INFO: Enabled EDT checker, wrongful access to gui from non EDT thread will be printed to console
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
Oct 25, 2015 9:08:32 PM sun.awt.X11.XToolkit processException
WARNING: Exception on Toolkit thread
java.lang.ArrayIndexOutOfBoundsException: 85
	at sun.awt.X11.XEvent.getFieldsAsString(XEvent.java:86)
	at sun.awt.X11.XWrapperBase.toString(XWrapperBase.java:37)
	at sun.awt.X11.XEvent.toString(XEvent.java:8)
	at java.lang.String.valueOf(String.java:2994)
	at sun.util.logging.PlatformLogger$JavaLoggerProxy.doLog(PlatformLogger.java:626)
	at sun.util.logging.PlatformLogger.finer(PlatformLogger.java:387)
	at sun.awt.X11.XToolkit.run(XToolkit.java:586)
	at sun.awt.X11.XToolkit.run(XToolkit.java:532)
	at java.lang.Thread.run(Thread.java:745)

INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
Oct 25, 2015 10:09:18 PM sun.awt.X11.XToolkit processException
WARNING: Exception on Toolkit thread
java.lang.ArrayIndexOutOfBoundsException: 85
	at sun.awt.X11.XEvent.getFieldsAsString(XEvent.java:86)
	at sun.awt.X11.XWrapperBase.toString(XWrapperBase.java:37)
	at sun.awt.X11.XEvent.toString(XEvent.java:8)
	at java.lang.String.valueOf(String.java:2994)
	at sun.util.logging.PlatformLogger$JavaLoggerProxy.doLog(PlatformLogger.java:626)
	at sun.util.logging.PlatformLogger.finer(PlatformLogger.java:387)
	at sun.awt.X11.XToolkit.run(XToolkit.java:586)
	at sun.awt.X11.XToolkit.run(XToolkit.java:532)
	at java.lang.Thread.run(Thread.java:745)

INFO: Opening URL: https://josm.openstreetmap.de/


Expected results:
 I can use the franch cadastre to make edits to OSM.

Additional info:
Comment 1 Fedora Update System 2016-02-11 11:09:29 EST
josm-0-0.73.9329svn.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e0701726a8
Comment 2 Fedora Update System 2016-02-14 11:23:09 EST
josm-0-0.73.9329svn.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e0701726a8
Comment 3 Fedora Update System 2016-02-16 07:25:32 EST
josm-0-0.74.9329svn.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6544d9c2d2
Comment 4 Fedora Update System 2016-02-17 01:27:41 EST
josm-0-0.74.9329svn.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6544d9c2d2
Comment 5 Fedora Update System 2016-02-26 02:22:46 EST
josm-0-0.74.9329svn.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.