Bug 1275098 - [abrt] device-mapper-event: _timeout_thread(): dmeventd killed by SIGSEGV
[abrt] device-mapper-event: _timeout_thread(): dmeventd killed by SIGSEGV
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.2
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: LVM and device-mapper development team
cluster-qe@redhat.com
https://faf-report.itos.redhat.com/re...
abrt_hash:fb2d3cd4f3ca7f33ff5b127c9c9...
:
Depends On:
Blocks: 1313485 1295577
  Show dependency treegraph
 
Reported: 2015-10-25 17:30 EDT by Matěj Cepl
Modified: 2016-11-04 00:12 EDT (History)
10 users (show)

See Also:
Fixed In Version: lvm2-2.02.152-1.el7
Doc Type: Bug Fix
Doc Text:
dmeventd code has been updated to recent version which includes numerous fixes, including fixes for various possible segfaults.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.43 KB, text/plain)
2015-10-25 17:30 EDT, Matěj Cepl
no flags Details
File: cgroup (187 bytes, text/plain)
2015-10-25 17:30 EDT, Matěj Cepl
no flags Details
File: core_backtrace (4.19 KB, text/plain)
2015-10-25 17:30 EDT, Matěj Cepl
no flags Details
File: dso_list (2.60 KB, text/plain)
2015-10-25 17:30 EDT, Matěj Cepl
no flags Details
File: environ (117 bytes, text/plain)
2015-10-25 17:30 EDT, Matěj Cepl
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-25 17:30 EDT, Matěj Cepl
no flags Details
File: machineid (135 bytes, text/plain)
2015-10-25 17:31 EDT, Matěj Cepl
no flags Details
File: maps (11.80 KB, text/plain)
2015-10-25 17:31 EDT, Matěj Cepl
no flags Details
File: open_fds (461 bytes, text/plain)
2015-10-25 17:31 EDT, Matěj Cepl
no flags Details
File: proc_pid_status (1.02 KB, text/plain)
2015-10-25 17:31 EDT, Matěj Cepl
no flags Details
File: var_log_messages (575 bytes, text/plain)
2015-10-25 17:31 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2015-10-25 17:30:41 EDT
Version-Release number of selected component:
device-mapper-event-1.02.107-5.el7

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/sbin/dmeventd -f
crash_function: _timeout_thread
executable:     /usr/sbin/dmeventd
global_pid:     1062
kernel:         3.10.0-325.el7.x86_64
runlevel:       unknown
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (1 frames)
 #0 _timeout_thread at dmeventd.c:582

Potential duplicate: bug 1220856
Comment 1 Matěj Cepl 2015-10-25 17:30:49 EDT
Created attachment 1086287 [details]
File: backtrace
Comment 2 Matěj Cepl 2015-10-25 17:30:51 EDT
Created attachment 1086288 [details]
File: cgroup
Comment 3 Matěj Cepl 2015-10-25 17:30:52 EDT
Created attachment 1086289 [details]
File: core_backtrace
Comment 4 Matěj Cepl 2015-10-25 17:30:54 EDT
Created attachment 1086290 [details]
File: dso_list
Comment 5 Matěj Cepl 2015-10-25 17:30:56 EDT
Created attachment 1086291 [details]
File: environ
Comment 6 Matěj Cepl 2015-10-25 17:30:58 EDT
Created attachment 1086292 [details]
File: limits
Comment 7 Matěj Cepl 2015-10-25 17:31:00 EDT
Created attachment 1086293 [details]
File: machineid
Comment 8 Matěj Cepl 2015-10-25 17:31:03 EDT
Created attachment 1086294 [details]
File: maps
Comment 9 Matěj Cepl 2015-10-25 17:31:05 EDT
Created attachment 1086295 [details]
File: open_fds
Comment 10 Matěj Cepl 2015-10-25 17:31:07 EDT
Created attachment 1086296 [details]
File: proc_pid_status
Comment 11 Matěj Cepl 2015-10-25 17:31:09 EDT
Created attachment 1086297 [details]
File: var_log_messages
Comment 13 Zdenek Kabelac 2015-10-25 17:40:43 EDT
dmeventd has been redesigned and new code already went upstream.
Once we will have new package ready - we will ask for revaluation.

Old version had many design problems that has been addressed by new rewrite.

Common bug has been parallel work in libdm and lib lvm2 code.
Comment 14 Zdenek Kabelac 2015-10-29 08:22:52 EDT
I believe this is fixed with recent commits in dmeventd code in lvm2 2.02.133.
Comment 18 Mike McCune 2016-03-28 18:58:03 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 20 Corey Marthaler 2016-09-19 10:54:26 EDT
Marking verified (SanityOnly) like mentioned in comment #17. I have not seen
this issue during the regression test runs.

3.10.0-501.el7.x86_64

lvm2-2.02.165-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
lvm2-libs-2.02.165-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
lvm2-cluster-2.02.165-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-libs-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-event-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-event-libs-1.02.134-2.el7    BUILT: Wed Sep 14 09:01:43 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT
2016
Comment 22 errata-xmlrpc 2016-11-04 00:12:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html

Note You need to log in before you can comment on or make changes to this bug.