Bug 1275122 - Bluetooth firmware module fails to load
Bluetooth firmware module fails to load
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 20:24 EDT by Patrick O'Callaghan
Modified: 2017-02-10 02:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 09:29:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick O'Callaghan 2015-10-25 20:24:27 EDT
Description of problem: Bluetooth module fails to load


Version-Release number of selected component (if applicable):


How reproducible:
Solid

Steps to Reproduce:
1.Insert Bluetooth dongle
2.See error on dmesg output
3.

Actual results:
Direct firmware load for brcm/BCM20702A1-0a5c-21e8.hcd failed with error -2

Expected results:
Correct Bluetooth operation

Additional info:
Kernel 4.2.3-200.fc22.x86_64

Full dump:
[15213.074989] usb 3-1.2: new full-speed USB device number 6 using ehci-pci
[15213.164068] usb 3-1.2: New USB device found, idVendor=0a5c, idProduct=21e8
[15213.164074] usb 3-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[15213.164076] usb 3-1.2: Product: BCM20702A0
[15213.164079] usb 3-1.2: Manufacturer: Broadcom Corp
[15213.164081] usb 3-1.2: SerialNumber: 000272C6AB85
[15213.172082] Bluetooth: hci0: BCM: chip id 63
[15213.173129] Bluetooth: hci0: BCM20702A1 (001.002.014) build 0000
[15213.173307] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-21e8.hcd failed with error -2
[15213.173312] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e8.hcd not found
Comment 1 Josh Boyer 2015-10-26 09:29:36 EDT
This isn't a kernel problem.  Your system lacks the firmware file the driver is trying to load.

Fedora ships firmware from the upstream linux-firmware project.  This specific file is not contained in that project as Broadcom is somewhat reticent to publish their firmware files in a redistributable fashion.  You will need to find it on whatever site they ship it on and put it in the proper location.
Comment 2 Patrick O'Callaghan 2015-10-26 12:38:05 EDT
(In reply to Josh Boyer from comment #1)
> This isn't a kernel problem.  Your system lacks the firmware file the driver
> is trying to load.
> 
> Fedora ships firmware from the upstream linux-firmware project.  This
> specific file is not contained in that project as Broadcom is somewhat
> reticent to publish their firmware files in a redistributable fashion.  You
> will need to find it on whatever site they ship it on and put it in the
> proper location.

I am aware that the firmware is not part of Fedora, however I installed it (see http://plugable.com/2014/06/23/plugable-usb-bluetooth-adapter-solving-hfphsp-profile-issues-on-linux) several months ago and it has worked correctly every day until now. The firmware file is in place, has the correct name, the correct owner and the correct permissions. I've also downloaded it again to make sure that the file is not corrupt.
Comment 3 Patrick O'Callaghan 2015-10-26 12:54:48 EDT
(In reply to Patrick O'Callaghan from comment #2)
> (In reply to Josh Boyer from comment #1)
> > This isn't a kernel problem.  Your system lacks the firmware file the driver
> > is trying to load.
> > 
> > Fedora ships firmware from the upstream linux-firmware project.  This
> > specific file is not contained in that project as Broadcom is somewhat
> > reticent to publish their firmware files in a redistributable fashion.  You
> > will need to find it on whatever site they ship it on and put it in the
> > proper location.
> 
> I am aware that the firmware is not part of Fedora, however I installed it
> (see
> http://plugable.com/2014/06/23/plugable-usb-bluetooth-adapter-solving-hfphsp-
> profile-issues-on-linux) several months ago and it has worked correctly
> every day until now. The firmware file is in place, has the correct name,
> the correct owner and the correct permissions. I've also downloaded it again
> to make sure that the file is not corrupt.

(Replying to myself, sorry)

I've checked the journalctl logs and it turns out that the same load error has been present frequently in the past, however it has not prevented BT from working. In fact it still works with some devices (headphones) but not with my BT mouse, which is why I noticed the problem. The mouse itself does work on a different system (with built-in BT hardware and a different driver).
Comment 4 Patrick O'Callaghan 2015-10-26 13:52:01 EDT
I changed the BT dongle for an old one (different model) and the problem seems to have gone. I assume it was h/w all along.
Comment 5 Wade Mealing 2017-02-10 02:22:21 EST
One thing to note is that this chip was looking for the A1 firmware, and you were running the A0 chip.  Maybe just a file rename may have solved the problem.

Note You need to log in before you can comment on or make changes to this bug.