Bug 127513 - Korean characters are input in reverse order.
Korean characters are input in reverse order.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-09 01:51 EDT by Jeongkyu Kim
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 04:33:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeongkyu Kim 2004-07-09 01:51:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
When I typed a, b and c in new mail window, it was shown as 'abc'.
However, when I typed equivalent Korean characters then it was shown
in wrong order - 'cba'.

The caret seemed not to move forward while I was typing. And the new
character pushed existing characters to the right. So, it was
progressing like below.

a
ba
cba


Version-Release number of selected component (if applicable):
evolution-1.5.9.2-1

How reproducible:
Always

Steps to Reproduce:
1. Activate iiimf-le-hangul
2. Open new mail window
3. Change into Korean input mode (ctrl-space)
4. Type couple of Korean alpabets
5. Check the order of characters
    

Additional info:

iiimf-le-hangul-11.4-64.svn1772 was used to input Korean character and
the ime works fine in another apps such as Mozilla and OpenOffice.
Comment 1 sangu 2004-07-21 10:52:05 EDT
This problem may be hangul input method(iiimf-le-hangul)'s bug. The
Same problem happens in imhangul 0.9.9. But this problem is fixed in
imhangul 0.9.10.

"iiimf-le-hangul" and "imhangul" are gtk-im-module.

http://kldp.net/tracker/index.php?func=detail&aid=300276&group_id=28&atid=100028

http://kldp.net/forum/forum.php?forum_id=1705
Comment 2 Jeongkyu Kim 2004-07-26 22:28:39 EDT
Hi sangu,

Thanks for the useful information. From the answer of my query in the
project page, I got better understanding of the problem. The
developer, Choe Hwanjin, who semms to lead both projects mentioned
that iiimf-le-hangul was initially designed to avoid the problem, but
it might be caused by how gtkhtml-3.1 handles im context. It thus
appears to me that this is not a bug of evolution. However, I could
not find iiimf-le-hangul component for FC. Would it be better to close
this bug here? What do you think Dave?

Comment 3 Dave Malcolm 2004-09-24 14:15:21 EDT
I'm sorry that this bug has gone for a while without activity.

Both gtkhtml3 and the iiimf code have gone through a number of
versions since this bug was filed, so it would be useful if you try
grabbing the latest Rawhide versions and seeing how well Korean input
is working (both within Evolution, and in general)
Comment 4 Jeongkyu Kim 2004-09-27 04:33:05 EDT
Hi Dave,

This issues seems fixed in the latest Rawhide version. Korean input is
working well with Evelution and also in general.

Note You need to log in before you can comment on or make changes to this bug.