Bug 12752 - 2.2.16 compilation glitches
2.2.16 compilation glitches
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-20 04:42 EDT by Michael Tokarev
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-20 04:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Tokarev 2000-06-20 04:42:50 EDT
Two of them so far (and missing links to linux and asm in kernel-headers):

New aacraid won't compile if current (from compiling kernel) kernel
headers not installed.  In Makefile in drivers/scsi/aacraid:

----
#  Remember that we're doing a chdir one level lower, so we need an extra 
../
INCS= \
        -I./include \
        -I/usr/src/linux/include -I/usr/src/linux/drivers/scsi
----

Note the two -I/usr/src/linux/... includes.  Those should be
-I$(TOPDIR)/include (unnecessary and bogus, since installed kernel headers
is not the same as for currently complied kernel, them are from previous
kernel at least) and -I$(TOPDIR)/drivers/scsi.
This new driver is in redhat's patches.

And the second one.  Latest gcc from rawhide (2.96-20000606)
won't compile kernel anymore, it fails on math emulation package
on i386.  I know about issues with compiling kernels with gcc,
but all my previous kernels was compiled by latest gcc (at time
of compiling) release from rawhide, and so far all was ok.
Now (as I don't need math emu on 486 and up) I can just edit
config files (kernel-2.2.16-i?86.config etc) and change math emu
to n.
Comment 1 Michael K. Johnson 2000-08-04 16:52:24 EDT
I believe this to be fixed in Pinstripe; re-open if
I'm wrong.
Comment 2 Michael Tokarev 2000-08-06 16:55:02 EDT
Ok, this two glitches was gone away.
Math ok, and aacraid also.  This issue should be closed now.
(With others remains, like e.g. problems with memcpy() and new gcc,
problems with usage of preprocessor in kernel and new gcc again;
but those are another stories...)
Thanks.

Note You need to log in before you can comment on or make changes to this bug.