Bug 1275210 - [hosted-engine-setup] hosted-engine.conf must be modified with the new SPUUID after Importing the HE storage domain to the DC
[hosted-engine-setup] hosted-engine.conf must be modified with the new SPUUID...
Status: CLOSED DUPLICATE of bug 1269768
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.0
x86_64 Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
integration
:
Depends On: 1269768
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 05:43 EDT by Elad
Modified: 2015-10-27 08:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 08:13:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ebenahar: planning_ack?
ebenahar: devel_ack?
ebenahar: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Elad 2015-10-26 05:43:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Elad 2015-10-26 05:45:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Elad 2015-10-26 06:04:14 EDT
Description of problem:
Hosted engine deployment requires manual import of the hosted-engine storage domain to the setup. This import causes the hosted-engine VM to loose its connectivity to its storage which located on the HE storage domain. This happens since the SPUUID is changed in the storage domain metadata the the SPUUID of the new pool.
This requires modification of /etc/ovirt-hosted-engine/hosted-engine.conf with the new SPUUID. 

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted engine over file based storage (NFS or Gluster)
2. Import the HE storage domain to the setup
3. Hosted engine VM comes down

Actual results:
/etc/ovirt-hosted-engine/hosted-engine.conf with the new SPUUID. This flow is not user friendly.

Expected results:
User is not supposed to deal with this configuration.
Comment 3 Simone Tiraboschi 2015-10-26 06:20:28 EDT
That unfriendly flow was just a temporary workaround for:
https://bugzilla.redhat.com/show_bug.cgi?id=1269768

It should disappear as soon as we solve that.
Comment 4 Sandro Bonazzola 2015-10-27 08:13:12 EDT
Closing as duplicate of bug #1269768

*** This bug has been marked as a duplicate of bug 1269768 ***

Note You need to log in before you can comment on or make changes to this bug.