Bug 1275215 - crash when plugging a monitor
crash when plugging a monitor
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rui Matos
Desktop QE
:
Depends On:
Blocks: 1219476 1275651
  Show dependency treegraph
 
Reported: 2015-10-26 05:47 EDT by Rui Matos
Modified: 2015-11-19 02:21 EST (History)
3 users (show)

See Also:
Fixed In Version: mutter-3.14.4-17.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:21:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 756796 None None None Never

  None (edit)
Description Rui Matos 2015-10-26 05:47:21 EDT
With the latest 7.2 packages, mutter sometimes crashes when plugging in monitors:

Program received signal SIGSEGV, Segmentation fault.
meta_monitor_manager_xrandr_read_current (manager=manager@entry=0x17332a0) at backends/x11/meta-monitor-manager-xrandr.c:612
612		  meta_output->preferred_mode = meta_output->modes[0];
(gdb) bt
#0  meta_monitor_manager_xrandr_read_current (manager=manager@entry=0x17332a0) at backends/x11/meta-monitor-manager-xrandr.c:612
#1  0x00007fe870f2dc73 in meta_monitor_manager_xrandr_handle_xevent (manager_xrandr=0x17332a0, event=0x7ffcbf492c10)
    at backends/x11/meta-monitor-manager-xrandr.c:1157
#2  0x00007fe870f2b483 in x_event_source_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>)
    at backends/x11/meta-backend-x11.c:212
#3  0x00007fe86cb3879a in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#4  0x00007fe86cb38ae8 in g_main_context_iterate.isra.24 () from /lib64/libglib-2.0.so.0
#5  0x00007fe86cb38dba in g_main_loop_run () from /lib64/libglib-2.0.so.0
#6  0x00007fe870f52bc8 in meta_run () at core/main.c:473
#7  0x0000000000402455 in main ()


There are two related bugs filed upstream about this:
https://bugzilla.gnome.org/show_bug.cgi?id=756796
https://bugzilla.gnome.org/show_bug.cgi?id=756660
Comment 3 errata-xmlrpc 2015-11-19 02:21:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.