Bug 1275222 - Report "Failed to unpersist /etc/pki/consumer/key.pem" during auto-install with rhn parameters
Summary: Report "Failed to unpersist /etc/pki/consumer/key.pem" during auto-install wi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-3.6.1
: 3.6.0
Assignee: Ryan Barry
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-26 10:00 UTC by wanghui
Modified: 2016-03-09 14:41 UTC (History)
11 users (show)

Fixed In Version: ovirt-node-3.6.0-0.22.20151126git72acbb2.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:41:25 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
/var/log/ovirt-node.log file (16.05 KB, text/plain)
2015-10-26 10:00 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 48035 master MERGED [rhn] Don't try to unpersist files unless they're persisted Never
oVirt gerrit 49032 ovirt-3.6 MERGED [rhn] Don't try to unpersist files unless they're persisted Never

Description wanghui 2015-10-26 10:00:57 UTC
Created attachment 1086436 [details]
/var/log/ovirt-node.log file

Description of problem:
It will report "Failed to unpersist /etc/pki/consumer/key.pem" during auto-install with rhn parameters.
=========================================================================================================
2015-10-26 07:38:01,108      ERROR Failed to unpersist "/etc/pki/consumer/key.pem"
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/__init__.py", line 600, in unpersist
    self._unpersist_file(abspath)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/__init__.py", line 648, in _unpersist_file
    mount.umount(abspath)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/mount.py", line 109, in umount
    raise OSError(errno, os.strerror(errno))
OSError: [Errno 22] Invalid argument
2015-10-26 07:38:01,112      ERROR Failed to unpersist "/etc/pki/consumer/cert.pem"
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/__init__.py", line 600, in unpersist
    self._unpersist_file(abspath)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/__init__.py", line 648, in _unpersist_file
    mount.umount(abspath)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/mount.py", line 109, in umount
    raise OSError(errno, os.strerror(errno))
OSError: [Errno 22] Invalid argument

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Auto clean install rhev-hypervisor7-7.2-20151025.0.el7ev with follow parameters.
BOOTIF=em1 storage_init=/dev/sda adminpw=4DHc2Jl0D05xk rhn_username=***** rhn_password=***** firstboot
2. Check the installation process

Actual results:
1. It reports "Failed to unpersist /etc/pki/consumer/key.pem" during auto-install. And the auto-installation can be succeed.

Expected results:
1. It should not report such error.

Additional info:

Comment 1 Fabian Deutsch 2015-11-02 14:00:15 UTC
Raising priority because it could be an issue with the general persistence.

Comment 2 Fabian Deutsch 2015-11-17 13:09:04 UTC
Raising priority, because it's blocking some test flows.

Comment 5 wanghui 2015-12-15 07:55:48 UTC
Test version: 
rhev-hypervisor7-7.2-20151210.1
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch

Test steps:
1. Auto clean install rhev-hypervisor7-7.2-20151025.0.el7ev with follow parameters.
BOOTIF=em1 storage_init=/dev/sda adminpw=4DHc2Jl0D05xk rhn_username=***** rhn_password=***** firstboot
2. Check the installation process

Test result:
1. No "Failed to unpersist /etc/pki/consumer/key.pem" error.

So this issue is fixed in ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch. Change the status to verified.

Comment 7 errata-xmlrpc 2016-03-09 14:41:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.