Bug 1275223 - /var/log/messages is flooded with pacemaker messages each time "pacemakerd -$" is called
/var/log/messages is flooded with pacemaker messages each time "pacemakerd -...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.8
Assigned To: Andrew Beekhof
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 06:03 EDT by Josef Zimek
Modified: 2016-05-10 19:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: pacemaker-1.1.14-1.1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 19:52:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Zimek 2015-10-26 06:03:27 EDT
Description of problem:

The syslog logfile  /var/log/messages is flooded with similar messages (just different PID) - actually repeated all 20s:

Sep 10 13:53:09 rhlios2 pacemakerd[28246]:   notice: crm_add_logfile: Additional logging available in /var/log/cluster/corosync.log

in old RHEL6.5 this message was not seen.



Version-Release number of selected component (if applicable):

RHEL 6.7
pacemaker-1.1.12-8.el6.x86_64


How reproducible:
always


Steps to Reproduce:
resource agents are calling the "pacemakerd -$" periodically, 
And each call still generates the additional line into the messages file.

So the problem is the combination of the postgres & mysql resource agent scripts (using the common   "ocf-shellfuncs" )
and the new implementation of the pacemakerd  logging output.

- Either the "pacemakerd" skips the line in the logging when only called with "-$" to get the installed version 
- or the script function "ocf_local_nodename()" inside the common part of included  "ocf-shellfuncs" may not call the "pacemakerd -$" 

You can easily check when calling manually the "pacemakerd -$"  --> this always generates a logging message in RHEL 6.7, 
if you do the same call in RHEL 6.5 no entry in /var/log/messages is written.


Actual results:


Expected results:


Additional info:
Comment 2 Andrew Beekhof 2016-01-10 18:54:23 EST
Probably both.

The line shouldn't be logged and that function should likely use CRM_FEATURE_SET instead.
Comment 3 Ken Gaillot 2016-01-11 18:33:50 EST
I can reproduce this with the stock 6.7 packages, but not the latest 6.8 build, so I believe this is already fixed.
Comment 9 errata-xmlrpc 2016-05-10 19:52:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0856.html

Note You need to log in before you can comment on or make changes to this bug.