This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275248 - RFE: Multi-monitor setup: on / off fullscreen mode should be consistent
RFE: Multi-monitor setup: on / off fullscreen mode should be consistent
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.3
Unspecified Unspecified
low Severity unspecified
: rc
: 7.3
Assigned To: Virt Viewer Maint
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 07:28 EDT by Andrei Stepanov
Modified: 2016-02-18 21:32 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 17:07:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Stepanov 2015-10-26 07:28:15 EDT
The bug is about multi screen setup with real monitors.

virt-viewer has a menu to go to fullscreen mode / leave fullscreen mode

There is different behavior for "Leave fullscreen" button.

Particularly
 
1. If user connects in fullscreen, "Leave fullscreen" occurs in all displays.

2. Other ways to activate/deactivate fullscreen mode works independently for each display.

There should be consistency.
Comment 2 Fabiano Fidêncio 2015-10-26 08:22:01 EDT
Andrei,

As far as I understand this is the expected behavior.
Please, take a look on these patches were the behavior/requirements for virt-viewer in fullscreen multimonitor mode is/are described.

https://www.redhat.com/archives/virt-tools-list/2015-June/msg00074.html

This patch should be part of virt-viewer, let's try to revisit it soon.
Comment 3 Fabiano Fidêncio 2015-10-26 16:59:29 EDT
To be a bit more specific. It's related to item D5 of the link I posted in the comment 2.

And here is a chat I had with Jonathon about this:
18:24 <  fidencio> jjongsma: about multimonitor fullscreen behaviour. when you open remote-viewer on fullscreen mode (-f) and then you 
                   leave fullscreen mode, we do it for all windows. shouldn't we do that only for the window where the user clicked to 
                   leave fullscreen?
18:38 <~ jjongsma> fidencio, this is a long-standing question. We've treated this differently since I've been on the project, but I'm 
                   not sure whether we really should.
18:46 <  fidencio> I personally tend to say that the current behaviour makes sense, as long as it's documented somewhere
18:46 <~ jjongsma> fidencio, I think the historical explanation is that fullscreen mode used to be an app-level option
18:46 <~ jjongsma> e.g. you could only have all windows fullscreen or all non-fullscreen
18:46 <~ jjongsma> then elmarco introduced per-window fullscreen at some point
18:47 <~ jjongsma> and startup fullscreen remained with the old behavior

Getting back to the link posted in the comment 2, it says: "that will need to be changed.", so, let's change it.
Comment 5 Fabiano Fidêncio 2015-10-27 09:05:40 EDT
Here is a proposed patch:
http://www.redhat.com/archives/virt-tools-list/2015-October/msg00088.html

OTOH, it is a quite big change that would affect pretty much all costumers using fullscreen.
So, is it a valid request? I would like to hear something from PM wrt this bug.

Note You need to log in before you can comment on or make changes to this bug.