This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127525 - hfsplus driver does not translate '/' characters
hfsplus driver does not translate '/' characters
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 08:57 EDT by Paul W. Frields
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 11:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Convert HFS+ '/' filenames to ':' and back (542 bytes, patch)
2004-07-09 09:11 EDT, Paul W. Frields
no flags Details | Diff

  None (edit)
Description Paul W. Frields 2004-07-09 08:57:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
(All FC1 kernels have had this problem.)

HFS+ allows any file name character except a colon (:), including
slashes (/), which can cause a problem with Linux. Users will be
unable to deal with these files since an embedded '/' character
consistently makes the shell generate a "file not found" error since
it is looking in a non-existent path.

The standard HFS driver already has support for munging '/' characters
into ':' to play nicely with Linux shells. This should be fixed in the
2.4 kernel for both FC1 and RHEL 3, since it is a trivial problem, and
many people will not be moving to 2.6 yet.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2197.nptl

How reproducible:
Always

Steps to Reproduce:
1. Attach/insert HFS+ volume on any media which contains a file using
a '/' character.
2. Mount or use modprobe hfsplus to address media.
3. Try to address aforementioned file.

Actual Results:  Error is always generated.

Expected Results:  Filename should be translated '/' -> ':' on the way
from the media, and vice versa to prevent writing illegal characters
to the media.

Additional info:  The next post will attach a patch to fix the problem.
Comment 1 Paul W. Frields 2004-07-09 09:11:32 EDT
Created attachment 101745 [details]
Convert HFS+ '/' filenames to ':' and back
Comment 2 Paul W. Frields 2004-08-03 11:52:18 EDT
Given Florian's comments at
<http://redhat.com/archives/fedora-devel-list/2004-August/msg00069.html>,
it's probably better to just close this as fixed in current release.
Interested parties should be able to find this via a Bugzilla search.

Just in case: hfsplus hfs+ filename colon slash

Note You need to log in before you can comment on or make changes to this bug.