Bug 1275281 - Subscription of overcloud nodes uses the old rhel-7-server-rh-common-rpms repo instead of the current rhel-7-server-satellite-tools-6.1-rpms
Subscription of overcloud nodes uses the old rhel-7-server-rh-common-rpms rep...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Mike Burns
Alexander Chuzhoy
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 08:57 EDT by David Gurtner
Modified: 2016-04-15 10:30 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.14-4.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Previously, we were using an old repository for satellite rpms. Consequence: We might miss important updates Fix: The right repo is now being used Result: We should get updates correctly
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 10:30:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 245895 None None None Never

  None (edit)
Description David Gurtner 2015-10-26 08:57:20 EDT
Description of problem:

The snippet to register overcloud nodes to Satellite or the Portal tries to install katello-agent from the old rhel-7-server-rh-common-rpms repo instead of the current rhel-7-server-satellite-tools-6.1-rpms

Version-Release number of selected component (if applicable):

python-rdomanager-oscplugin-0.0.10-8.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch

How reproducible:

Always

Steps to Reproduce:
1. Deploy overcloud with RHEL registration, i.e. openstack overcloud deploy [...] --rhel-reg --reg-method satellite --reg-force --reg-org Default_Organization --reg-sat-url http://satellite.example.com --reg-activation-key app-osp
2.
3.

Actual results:

rhel-7-server-rh-common-rpms repo gets used for katello installer installation.

Expected results:

rhel-7-server-satellite-tools-6.1-rpms repo should be used

Additional info:

[root@overcloud-controller-0 ~]# grep -r -E "satellite_repo|katello-agent" /usr/libexec/os-refresh-config/pre-configure.d/06-rhel-registration
satellite_repo="rhel-7-server-rh-common-rpms"
        repos="$repos --enable ${satellite_repo}"
        echo "Installing katello-agent"
        yum install -y katello-agent || true # needed for errata reporting to satellite6
        subscription-manager repos --disable ${satellite_repo}
Comment 2 Harald Jensås 2015-11-19 23:21:41 EST
Registration is done by a script in the triple-O templates, the 06-rhel-registration also runs. But it does'nt do anything, just logs that registration with user/password is deprecated and exits.

openstack-tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/scripts/rhel-registration

FIX the template for Satellite >= 6.1:
sed -i 's/rhel-7-server-rh-common-rpms/rhel-7-server-satellite-tools-6.1-rpms/g openstack-tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/scripts/rhel-registration
Comment 7 Alexander Chuzhoy 2016-04-12 13:42:08 EDT
Verified:
Environment:
openstack-tripleo-heat-templates-0.8.14-7.el7ost.noarch



[root@overcloud-controller-0 ~]# yum list katello-agent

katello-agent.noarch     2.2.6-1.el7sat    rhel-7-server-satellite-tools-6.1-rpms
Comment 9 errata-xmlrpc 2016-04-15 10:30:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0637.html

Note You need to log in before you can comment on or make changes to this bug.