Bug 1275290 - [rhevm-appliance] engine-setup requests firewalld instead of iptables for rhel6 based appliance
[rhevm-appliance] engine-setup requests firewalld instead of iptables for rhe...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Anatoly Litovsky
Gonza
:
Depends On:
Blocks: 1217106
  Show dependency treegraph
 
Reported: 2015-10-26 09:33 EDT by Gonza
Modified: 2016-03-09 16:44 EST (History)
4 users (show)

See Also:
Fixed In Version: rhevm-appliance-20151029.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 16:44:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine-setup log (253.14 KB, text/plain)
2015-10-26 09:33 EDT, Gonza
no flags Details

  None (edit)
Description Gonza 2015-10-26 09:33:51 EDT
Created attachment 1086517 [details]
engine-setup log

Description of problem:
rhevm-appliance "engine-setup --offline --config-append=ovirt-engine-answers" fails with:
2015-10-26 08:28:50 ERROR otopi.context context._executeMethod:165 Failed to execute stage 'Setup validation': Firewall manager firewalld is not available

# cat ovirt-engine-answers | grep firewall
OVESETUP_CONFIG/firewallManager=str:firewalld

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 (Santiago)

Version-Release number of selected component (if applicable):
rhevm-appliance-20151022.1-1

How reproducible:
100%

Steps to Reproduce:
1. engine-image-uploader -e {export_domain} upload rhevm-appliance-20151022.1-1.x86_64.rhevm.ova
2. Click on {export_domain} under Storage tab
3. Click on Template Import tab and import the uploaded image
4. Create a new VM using the imported template
5. Run Once the new VM with Initial Run > Use cloud-Init enabled and set root password under the Authentication parameters
6. Access the VM console and run "engine-setup --offline --config-append=ovirt-engine-answers"

Actual results:
engine-setup fails

Expected results:
engine-setup successfully installed

Additional info:
firewalld is the default firewall manager for centos 7 but this appliance was created for rhel6.7 which uses iptables as default firewall manager.
Comment 1 Fabian Deutsch 2015-11-02 03:31:35 EST
The u/s appliance is based on CentOS 7 , the d/ sone on RHEL 6, this is causing the difference.

To align u/s and d/s I'd suggest to disable firewalld on u/s and use iptables as well.
Comment 2 Yaniv Lavi (Dary) 2015-11-02 09:22:01 EST
Can we fix this for Beta1?
Comment 5 Gonza 2015-11-04 07:59:16 EST
Verified with:
rhevm-appliance-20151029.2-1

engine-setup successfully installed.
Comment 7 errata-xmlrpc 2016-03-09 16:44:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0385

Note You need to log in before you can comment on or make changes to this bug.