Bug 1275321 - Apps do not register mouse events with xwayland on the primary screen on a multi-display setup
Apps do not register mouse events with xwayland on the primary screen on a mu...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: wayland (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 10:04 EDT by fred
Modified: 2015-10-30 08:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 08:30:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred 2015-10-26 10:04:32 EDT
Description of problem:
When I click on an item on, for example, a webpage link under firefox or a link in chrome, or Xterm, nothings happens. Hover events are not propagated to the app either. It seems that the mouse events are ignored by the apps as long as their window is on the primary screen. If I move firefox or chrome on the secondary screen, mouse events (click, hover, ... ) are registered properly.

Terminal, nautilus and native wayland apps are working properly. Xterm does not.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xwayland 1.18.0-0.5.20150907.fc23

How reproducible:
Always

Steps to Reproduce:
1. Have a two display setup
2. Start firefox or Xterm and move it on differents screens
3. Move the on the different displays and notice how they don't react to mouse events on one of them

Actual results:
Nothing happens on any mouse event on one screen

Expected results:
Mouse events should not depend on the display they're aiming at.

Additional info:

Running f23 upgraded from fc22.
Comment 1 fred 2015-10-26 10:31:48 EDT
Looks like the bug disappeared, even though I tried many times before submitting... It might happen when one register a NEW secondary screen during the session though.
Comment 3 fred 2015-10-30 08:30:17 EDT
Definitely looks like it's the same bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.