Bug 127534 - [RFI] Compile libgcj with --enable-java-awt=gtk
Summary: [RFI] Compile libgcj with --enable-java-awt=gtk
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 127537
TreeView+ depends on / blocked
 
Reported: 2004-07-09 15:14 UTC by W. Michael Petullo
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: gcc-java-3.4.1-10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-04 17:58:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2004-07-09 15:14:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.8

Description of problem:
I would like to see gcc-java built to support AWT.  A GTK AWT peer may
be built by giving gcc's configure script the --enable-java-awt=gtk
argument.  Though its implementation is not complete, it would be nice
to be able to start testing gcc's GTK AWT peer using a Fedora-provided
package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to execute a java application that uses AWT and was compiled using
Fedora's gcc-java package.
    

Additional info:

Comment 1 W. Michael Petullo 2004-08-22 02:39:15 UTC
I looks like the GTK AWT peer is built as of gcc 3.4.1-8.  However, on
PowerPC things don't seem to work quite right.

"gcj --main=HelloWorldAWT HelloWorldAWT.java" compiles fine.

"LD_PRELOAD=/usr/lib/gcc/ppc64-redhat-linux/3.4.1/lib-gnu-java-awt-peer-gtk.so
./a.out" executes fine.

But "./a.out" says:

Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit:
gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit() (/usr/lib/libgcj.so.5.0.0)
[...]

Why would the explicit LD_PRELOAD be needed?

Comment 2 W. Michael Petullo 2004-09-04 17:58:55 UTC
This seems to be fixed in gcc-java-3.4.1-10.  LD_PRELOAD is no longer
needed.


Note You need to log in before you can comment on or make changes to this bug.