Bug 127535 - logical volume sizes wrong in disk druid
logical volume sizes wrong in disk druid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 128556 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 11:19 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-04 15:00:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-07-09 11:19:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Disk druid displays logical volume sizes as one tenth of their actual
size.  E.g., a LV with 8192MiB (2048 extends x 4MiB/extend) is
displayed as 819.2 MiB.  Used space reflects this 1/10 ratio, but the
total space is correct, so the free space ends up much larger than
real.  I wonder what happens if I actually ask it to create a huge LV
taking up all of the space it claims to be free.

Version-Release number of selected component (if applicable):
anaconda-10.0.1-2.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.Boot the installer on a box with LVM1 volumes
2.Proceed to disk druid

Actual Results:  Pre-existing partitions are shown as taking up 1/10
of their actual size.

Expected Results:  Size should be correct.

Additional info:
Comment 1 Alexandre Oliva 2004-07-09 11:24:11 EDT
Just noticed that the number displayed as the size of the volume group
is given in KiB, even though it column says Size (MB).  It's
nonsensical like this:

LVM Volume Groups
  all                     ...    119201792
     tettnang  ext                 819.2

correct would have ben

  all                    ...           116408
     tettnang ext                   8192

Total space is displayed in the correct units in the Edit LVM Volume
Group window, but LV size is still off by a factor of 10.  Ditto in
the Edit Logical Volume window.
Comment 2 Jeremy Katz 2004-07-09 11:45:03 EDT
Can you attach the /tmp/anaconda.log?
Comment 3 Alexandre Oliva 2004-07-09 14:43:39 EDT
Here are the relevant bits.  Let me know if you'd like the entire log,
or if I missed something you wanted to see.

* moving (1) to step partitionobjinit
* pv is /dev/hda1 in vg all, size is 61031317504
* pv is /dev/hde1 in vg all, size is 61031317504
* vg all, size is 122062635008
* lv is all/fc3test, size of 858993459
* lv is all/l, size of 6158915993
* lv is all/mm, size of 3221225472
* lv is all/swap, size of 91435827
* lv is all/tettnang, size of 858993459
* moving (1) to step autopartitionexecute
* In growLogicalVolumes, considering VG VG Request -- name: all 
uniqueID: 100000
  format: 0 pesize: 32768  
  physvols: [3, 6]
* No growable logical volumes defined.
* Used size vs. available for vg all:  10670 119201792.0
Comment 4 Jeremy Katz 2004-07-12 14:48:44 EDT
Fixed in CVS
Comment 5 Jeremy Katz 2004-07-26 23:51:13 EDT
*** Bug 128556 has been marked as a duplicate of this bug. ***
Comment 8 Alexandre Oliva 2004-09-04 15:00:51 EDT
Confirmed, at least in text mode.  I couldn't get to a graphical
install with the latest test tree.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.