Bug 1275357 - missing libmpxwrappers.so.0 in gcc-libraries
missing libmpxwrappers.so.0 in gcc-libraries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc-libraries (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marek Polacek
Michael Petlan
:
Depends On: 1275356
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 12:05 EDT by Miroslav Franc
Modified: 2017-04-12 15:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: gcc-libraries-5.2.1-2.1.1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275356
Environment:
Last Closed: 2016-05-10 17:39:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0843 normal SHIPPED_LIVE gcc-libraries bug fix and enhancement update 2016-05-10 18:42:41 EDT

  None (edit)
Description Miroslav Franc 2015-10-26 12:05:17 EDT
+++ This bug was initially created as a clone of Bug #1275356 +++

Description of problem:
gcc-libraries version of libmpx is missing libmpxwrappers.so.0 library.

Version-Release number of selected component (if applicable):
libmpx-5.2.1-2.1.el7


Steps to Reproduce:
0. enable dts-4
1. echo 'int main (void) { return 0; }' | gcc -xc -  -mmpx -fcheck-pointer-bounds -o oops
2. uninstall dts-4 libmpx
3. install gcc-libraries version of  libmpx
4. ./oops

Actual results:
./oops: error while loading shared libraries: libmpxwrappers.so.0: cannot open shared object file: No such file or directory



The same problem is on RHEL6 with libmpx-5.0.0-1.1.1.el6.
Comment 5 Michael Petlan 2016-02-09 07:53:25 EST
The version 5.2.1-2.1.1.el6 build does NOT contain libmpx. Bug solved.

VERIFIED.
Comment 7 errata-xmlrpc 2016-05-10 17:39:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0843.html

Note You need to log in before you can comment on or make changes to this bug.