Bug 1275365 - Problems in upgrade documentation
Problems in upgrade documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: 6.1
Assigned To: satellite-doc-list
satellite-doc-list
:
: 1259975 (view as bug list)
Depends On:
Blocks: 260381
  Show dependency treegraph
 
Reported: 2015-10-26 12:53 EDT by Deon Ballard
Modified: 2015-12-16 03:58 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 03:58:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2015-10-26 12:53:06 EDT
Document URL:
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/chap-Red_Hat_Satellite-Installation_Guide-Upgrading_Red_Hat_Satellite_Server_and_Capsule_Server.html#sect-Red_Hat_Satellite-Installation_Guide-Upgrading_Red_Hat_Satellite_Server_and_Capsule_Server-Upgrading_Red_Hat_Satellite 

This was reported from a customer.

1. /opt is required to be specific size. The customer case, the required size was 2G and 1.3G being set. The consultant increased the partition to 5G to get the upgrade going, but after the upgrade, the usage dropped down to 1.3G again.
The docs 1) need to specify some kind of sizing guidelines and 2) cover *what* the directory is being used for (like temporary storage during the upgrade).


2. The "katello-upgrade" example changes some settings from 6.0. The consultant specifies:

* Proxy settings. If you have special characters in the password, you need to get your escape characters right or it won't work.

* TFTP settings

I don't know if this is specified (I haven't checked), but I do know that the Satellite files are not supposed to be edited directly. If they are edited outside of the katello-* commands, then it loses that configuration if katello-install (and possibly katello-upgrade?) is ever run. 

3. Sat 6.1 requires new channel called "Red Hat Satellite 6.1 Tools
Channel," so the manifest needs to be recreated to include the channel. Also, recreating the manifest may require removing all the subscriptions from
the Satellite entry in the portal and adding things back. When the consultant did this, he encountered a database error. The error isn't in the email, but that may need to be mentioned or there may be a workaround.
Comment 17 Stephen Wadeley 2015-11-20 05:43:43 EST
(In reply to Deon Ballard from comment #0)

> 
> 2. The "katello-upgrade" example changes some settings from 6.0. The
> consultant specifies:
> 
> * Proxy settings. If you have special characters in the password, you need
> to get your escape characters right or it won't work.
> 

Re the above, see 

Bug 1259975 - RFE: Document list of characters to escape in password configuration
https://bugzilla.redhat.com/show_bug.cgi?id=1259975#c3
Comment 23 Hayley Hudgeons 2015-11-24 08:12:08 EST
*** Bug 1259975 has been marked as a duplicate of this bug. ***
Comment 24 Andrew Dahms 2015-11-25 22:21:39 EST
Raising needinfo against pondrejk.

Hi, Peter - would you be able to take a look at the changes for this bug?
Comment 25 Peter Ondrejka 2015-11-26 08:25:28 EST
Just checked :)

Note You need to log in before you can comment on or make changes to this bug.