Bug 1275366 - SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/lib/systemd/systemd-udevd.
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:043f9c3f16f07961bd7459566d7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 12:59 EDT by Phil
Modified: 2015-11-08 04:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 04:31:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil 2015-10-26 12:59:08 EDT
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/lib/systemd/systemd-udevd.

*****  Plugin catchall (100. confidence) suggests   **************************

If vous pensez que abrt-hook-ccpp devrait être autorisé à accéder getattr sur systemd-udevd file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:udev_exec_t:s0
Target Objects                /usr/lib/systemd/systemd-udevd [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           systemd-222-8.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-300.fc23.x86_64 #1 SMP Mon
                              Oct 5 15:42:54 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-26 17:55:11 CET
Last Seen                     2015-10-26 17:55:11 CET
Local ID                      9c7e5b26-5aaa-4f46-b1a2-78167b750555

Raw Audit Messages
type=AVC msg=audit(1445878511.997:741): avc:  denied  { getattr } for  pid=6981 comm="abrt-hook-ccpp" path="/usr/lib/systemd/systemd-udevd" dev="sda1" ino=1187693 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:udev_exec_t:s0 tclass=file permissive=0


Hash: abrt-hook-ccpp,abrt_dump_oops_t,udev_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-08 04:31:05 EST

*** This bug has been marked as a duplicate of bug 1276305 ***

Note You need to log in before you can comment on or make changes to this bug.