Bug 1275369 - combination of --check-engine-results and --report results in I/O warnings
combination of --check-engine-results and --report results in I/O warnings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openscap (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jan Černý
Marek Haicman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 13:03 EDT by Marek Haicman
Modified: 2016-11-03 23:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: openscap-1.2.9-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 23:32:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Haicman 2015-10-26 13:03:25 EDT
Description of problem:
When oscap is called with --check-engine-results and --report, at the very end of output is printed I/O warning as .result.xml file is not available.

Version-Release number of selected component (if applicable):
openscap-scanner-1.2.5-3.el7

How reproducible:
Reliably

Steps to Reproduce:
1. oscap xccdf eval --check-engine-results --report report.html xccdf.xml

Actual results:
Output is appended with these lines for each rule:

I/O warning : failed to load external entity ".../.result.xml"

Expected results:
No warning lines appended

Additional info:
There seems to be NO regression of functionality.
Comment 2 Jan Černý 2015-11-25 07:42:35 EST
This was fixed upstream maint-1.2 branch in commit https://github.com/jan-cerny/openscap/commit/adfe93ba38e5327c00fd3cd81a04f0ad708c8ec0
Comment 4 Mike McCune 2016-03-28 19:35:19 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Marek Haicman 2016-08-09 14:31:23 EDT
Verified fix on version openscap-1.2.10-1.el7.x86_64

=== OLD
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   openscap-1.2.5-3.el7.x86_64

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: --check-engine-results plus --report produces warnings (bz1275369)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Command 'scapSetupContent 0' (Expected 0, got 0)
:: [   PASS   ] :: Command 'oscap xccdf eval --check-engine-results --report report.html /tmp/tmp.4Zi1VSzC55/xccdf.xml &> output_bz1275369 ' (Expected 0, got 0)
:: [   PASS   ] :: File 'output_bz1275369' should contain 'www_rule_1' 
:: [   FAIL   ] :: File 'output_bz1275369' should not contain 'failed to load external entity' 
:: [   LOG    ] :: Duration: 1s
:: [   LOG    ] :: Assertions: 3 good, 1 bad
:: [   FAIL   ] :: RESULT: --check-engine-results plus --report produces warnings (bz1275369)


=== NEW
:: [   LOG    ] :: Package versions:
:: [   LOG    ] ::   openscap-1.2.10-1.el7.x86_64

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: --check-engine-results plus --report produces warnings (bz1275369)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: Command 'scapSetupContent 0' (Expected 0, got 0)
:: [   PASS   ] :: Command 'oscap xccdf eval --check-engine-results --report report.html /tmp/tmp.iQmjjEGfqm/xccdf.xml &> output_bz1275369 ' (Expected 0, got 0)
:: [   PASS   ] :: File 'output_bz1275369' should contain 'www_rule_1' 
:: [   PASS   ] :: File 'output_bz1275369' should not contain 'failed to load external entity' 
:: [   LOG    ] :: Duration: 1s
:: [   LOG    ] :: Assertions: 4 good, 0 bad
:: [   PASS   ] :: RESULT: --check-engine-results plus --report produces warnings (bz1275369)
Comment 8 errata-xmlrpc 2016-11-03 23:32:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2316.html

Note You need to log in before you can comment on or make changes to this bug.