Bug 1275374 - fail2ban package from EPEL6 is incompatible with RHEL6 iptables (-w option)
fail2ban package from EPEL6 is incompatible with RHEL6 iptables (-w option)
Status: CLOSED DUPLICATE of bug 1272681
Product: Fedora EPEL
Classification: Fedora
Component: fail2ban (Show other bugs)
el6
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 13:18 EDT by Richard Brittain
Modified: 2015-10-26 13:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 13:21:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Brittain 2015-10-26 13:18:30 EDT
Description of problem:
fail2ban package from EPEL6 is incompatible with RHEL6 iptables

Version-Release number of selected component (if applicable):
0.9.3-1.el6

How reproducible:
Unmodified fail2ban configuration sets 'lockingopt = -w' in /etc/fail2ban/action.d/iptables-common.conf, but RHEL6 iptables doesn't support -w flag,
so all iptables commands are rejected.

Steps to Reproduce:
1. service fail2ban start
2. iptables -L  => no fail2ban chains created
3. errors reporting misuse of '-w' option in iptables command line are sent to syslog.

Actual results:


Expected results:


Additional info:
Comment 1 Orion Poplawski 2015-10-26 13:21:01 EDT

*** This bug has been marked as a duplicate of bug 1272681 ***

Note You need to log in before you can comment on or make changes to this bug.