Bug 1275376 - docker-storage-setup: Fix the example text in /etc/sysconfig/docker-storage
docker-storage-setup: Fix the example text in /etc/sysconfig/docker-storage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 13:32 EDT by Vivek Goyal
Modified: 2015-12-08 10:36 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.8.2-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 10:36:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Goyal 2015-10-26 13:32:34 EDT
Description of problem:

Right now we have following text in docker-storage.sysconfig which is old and should not be used. Fix it.

# Example: Use a custom pair of raw logical volumes (one for metadata,
# one for data).
# DOCKER_STORAGE_OPTIONS = --storage-opt dm.metadatadev=/dev/mylogvol/my-docker-metadata --storage-opt dm.datadev=/dev/mylogvol/my-docker-data

Fix it. Possibly ask user to not edit this file directly and edit only /etc/sysconfig/docker-storage-setup.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2015-10-26 13:34:17 EDT
Lokesh please make the change.
Comment 3 Lokesh Mandvekar 2015-10-26 13:59:50 EDT
I'm hoping we get this change gets shipped in 7.2.1. dist-git has already moved to 1.9.0 but I could still work something out if people desire it be shipped in 7.1.6 and 7.2.0. lmk...
Comment 6 Alex Jia 2015-11-20 03:57:56 EST
There is no a value of DOCKER_STORAGE_OPTIONS in /etc/sysconfig/docker-storage on docker-1.8.2-10.el7.x86_64 now.

# cat /etc/sysconfig/docker-storage
# This file may be automatically generated by an installation program.
# Please DO NOT edit this file directly. Instead edit
# /etc/sysconfig/docker-storage-setup and/or refer to
# "man docker-storage-setup".

# By default, Docker uses a loopback-mounted sparse file in
# /var/lib/docker.  The loopback makes it slower, and there are some
# restrictive defaults, such as 100GB max storage.

DOCKER_STORAGE_OPTIONS=
Comment 8 errata-xmlrpc 2015-12-08 10:36:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2554.html

Note You need to log in before you can comment on or make changes to this bug.