Bug 1275383 - Data Tiering:Getting lookup failed on files in hot tier, when volume is restarted
Data Tiering:Getting lookup failed on files in hot tier, when volume is resta...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
: ZStream
Depends On: 1275158
Blocks: 1275382
  Show dependency treegraph
 
Reported: 2015-10-26 13:49 EDT by Dan Lambright
Modified: 2016-06-16 09:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275158
Environment:
Last Closed: 2016-06-16 09:41:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-26 16:21:48 EDT
REVIEW: http://review.gluster.org/12430 (cluster/tier do not log error message on lookup heal for files on hot tier) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Dan Lambright 2015-10-26 16:22:44 EDT
A file may exist on the hot tier because it was created before fix-layout reached it, or because it was created before the volume was stopped earlier. In either case this is not an error and should not be flagged as such, change the log to INFO.
Comment 3 Vijay Bellur 2015-10-27 18:18:22 EDT
REVIEW: http://review.gluster.org/12430 (cluster/tier do not log error message on lookup heal for files on hot tier) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 4 Vijay Bellur 2015-10-28 06:14:58 EDT
COMMIT: http://review.gluster.org/12430 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 3c6928f4daa6bd89ffa14049ba44337c049a9c89
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Mon Oct 26 14:19:24 2015 -0400

    cluster/tier do not log error message on lookup heal for files on hot tier
    
    On fix-layout heal files are scanned. Files found are exist on the hot or cold
    subvolume. Those not found in the cold tier would exist on the hot. They
    should not be flagged as an error.
    
    Replace INFO with TRACE for common tier migration logs. Frequent migration
    was growing the log files too quickly.
    
    On migratation failures, do not acrue files towards cycle limit's budget.
    
    Change-Id: Ie832ee07c43bce5477ae81c939d1fe8416a11615
    BUG: 1275383
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/12430
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Joseph Fernandes
Comment 5 Niels de Vos 2016-06-16 09:41:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.