Bug 1275395 - openshift-ansible currently sets the system hostname unnecessarily
openshift-ansible currently sets the system hostname unnecessarily
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 15:21 EDT by Jason DeTiberus
Modified: 2016-07-03 20:46 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 16:19:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2015-10-26 15:21:45 EDT
Previously we had to set the system hostname to workaround unconfigurable code paths that would use uname to lookup the system's hostname. 

This should no longer be necessary as we can override all of the necessary hostnames using configuration.
Comment 2 Jason DeTiberus 2015-11-18 15:07:58 EST
https://github.com/openshift/openshift-ansible/pull/924
Comment 3 Jason DeTiberus 2015-11-18 15:09:50 EST
We need to make sure that this change doesn't break OSE 3.0.0 deployments as well.
Comment 4 Ma xiaoqiang 2015-11-19 02:33:03 EST
If the system hostname is not resolved, we can get the error messages in the log

Nov 19 15:26:52 openshift-v3 atomic-openshift-master: E1119 15:26:52.466917   28396 common.go:722] Failed to lookup IP address for node test2.redhat.com: lookup test2.redhat.com: no such host
Nov 19 15:26:52 openshift-v3 atomic-openshift-master: F1119 15:26:52.466973   28396 flatsdn.go:27] SDN initialization failed: lookup test2.redhat.com: no such host

Is it worse to set the system hostname?
Comment 5 Jason DeTiberus 2015-11-19 10:42:57 EST
Can you provide the following files from the system that threw that error?
- /etc/origin/node/node-config.yaml
- /etc/ansible/facts.d/openshift.fact
- ansible inventory file
Comment 10 Johnny Liu 2015-11-30 00:49:46 EST
This is breaking QE's auto installation, so raise its priority.
Comment 12 Gaoyun Pei 2015-12-03 01:05:13 EST
This issue is also blocking the installation of atomic-openshift-installer when setting hostname needed, since there's no way to specify the value of openshift_set_hostname during the interaction. 

Test with:
openshift-ansible-3.0.16-1.git.61.2054960.el7aos.noarch
openshift-ansible-roles-3.0.16-1.git.61.2054960.el7aos.noarch
Comment 13 Brenton Leanhardt 2015-12-03 08:48:53 EST
Hi Gaoyun,

When you say there is no way to set openshift_set_hostname do you mean using atomic-openshift-installer?  Jason will probably chime in if I'm confused by I think you would would need to set it in your inventory:

https://github.com/openshift/openshift-ansible/pull/967/files#diff-786740a46e25ab5676fd83c2bf6b4197R155
Comment 14 Brenton Leanhardt 2015-12-03 08:53:46 EST
This should be testable with the latest puddle.

Also, I see now that Comment #12 is indeed referring to atomic-openshift-installer.  I'm removing needinfo.
Comment 15 Brenton Leanhardt 2015-12-03 08:54:24 EST
To be clear, this bug is for testing the feature by running ansible directly.
Comment 18 Ma xiaoqiang 2015-12-10 21:35:50 EST
Get the expected result. Move it to VERIFIED.
Comment 20 errata-xmlrpc 2015-12-17 16:19:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2667

Note You need to log in before you can comment on or make changes to this bug.