Bug 1275442 - Can't get cache statistics
Can't get cache statistics
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 19:16 EDT by Martin Vrabel
Modified: 2016-07-13 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-28 05:52:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Vrabel 2015-10-26 19:16:09 EDT
Description of problem:

Can't get cache statistics if the server has 2 caches and the name of one cache is a substring of the other cache name.

e.g. "default" and "default1"

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1. start JDG container with custom caches, so one cache name is a substring of the second cache name 
2. create a remote MBean
3. call some cache statistic
e.g. remote.cache.getAverageReadTime();

Actual results:
java.lang.RuntimeException: Could not get cache statistics: AverageReadTime
	at org.infinispan.arquillian.utils.MBeanUtils.getMBeanNamesByKeyValuePattern(MBeanUtils.java:113)
	at org.infinispan.arquillian.utils.MBeanObjectsProvider.getCacheStatisticsMBean(MBeanObjectsProvider.java:107)
	at org.infinispan.arquillian.model.RemoteInfinispanCache.getStatistics(RemoteInfinispanCache.java:111)
	at org.infinispan.arquillian.model.RemoteInfinispanCache.getAverageReadTime(RemoteInfinispanCache.java:127)
	at org.infinispan.server.test.rollingupgrades.HotRodRollingUpgradesIT.testHotRodRollingUpgradesDiffVersions(HotRodRollingUpgradesIT.java:95)


Expected results:
some number

Additional info:
Comment 2 Tristan Tarrant 2015-10-28 05:52:40 EDT
This looks like a bug in Infinispan Arquillian rather than in Infinispan.

Note You need to log in before you can comment on or make changes to this bug.