Bug 1275490 - ideapad_laptop prevents wireless from working on lenovo yoga 900
ideapad_laptop prevents wireless from working on lenovo yoga 900
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 00:19 EDT by Kevin Fenzi
Modified: 2015-12-16 09:36 EST (History)
14 users (show)

See Also:
Fixed In Version: kernel-4.2.6-301.fc23 kernel-4.2.6-201.fc22 kernel-4.2.7-200.fc22 kernel-4.2.7-300.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 04:52:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl -l from boot with blacklisted ideapad_laptop (593.38 KB, text/plain)
2015-10-27 00:19 EDT, Kevin Fenzi
no flags Details
[PATCH] ideapad-laptop: Add Lenovo Yoga 900 to no_hw_rfkill dmi list (1.27 KB, patch)
2015-11-06 07:50 EST, Hans de Goede
no flags Details | Diff
ideapad-laptop.c (24.05 KB, text/plain)
2015-11-06 07:51 EST, Hans de Goede
no flags Details

  None (edit)
Description Kevin Fenzi 2015-10-27 00:19:04 EDT
Created attachment 1086707 [details]
journalctl -l from boot with blacklisted ideapad_laptop

Booting a Lenovo yoga 900 gives no wireless or touchpad. 

I suspect we need to modify ideapad_laptop for it much like we had to a while back for the yoga 2 pro. 

( in bug 1021036 )

I have a dmesg from a boot where I blacklisteed ideapad_laptop and got bluetooth networking working attached. I've not been able to get wireless working by loading/unloading/blacklisting.
Comment 1 Kevin Fenzi 2015-10-27 00:20:33 EDT
Adding Hans here as he poked at the yoga 2 pro version of this issue back in the day. :)
Comment 2 Kevin Fenzi 2015-10-27 00:38:04 EDT
Some possibly usefull further info: 

$ cat /sys/class/dmi/id/product_version
Lenovo YOGA 900-13ISK

$ cat /sys/class/dmi/id/sys_vendor
LENOVO

$ cat /sys/class/dmi/id/product_version
Lenovo YOGA 900-13ISK
Comment 3 Hans de Goede 2015-10-27 04:25:52 EDT
Hi Kevin,

So you say that BOTH the wireless and the touchpad are not working. Great, I wish Lenovo would fix their stuff, rather then rely on us working around their issues. Ah well.

Lets start with getting the wireless fixed, since that is where the ideapad_laptop module comes into play I do not think that it has anything to do with the touchpad, but you never know. Please file a separate bug for the touchpad issue.

So first thing to do is run rfkill list, both with the module blacklisted and with it loaded. If with it loaded
the rfkill list says that ideapad_wlan is hw blocked, you've the same issue as on the yoga 2.

If this is the case then blacklisting may not be enough (as you are seeing), in this case can you build a kernel with a slightly modified drivers/platform/x86/ideapad-laptop.c and try that ?

Before building edit drivers/platform/x86/ideapad-laptop.c, you should find this line at or around line 901:

        priv->has_hw_rfkill_switch = !dmi_check_system(no_hw_rfkill_list);

Try changing that to:

        priv->has_hw_rfkill_switch = 0;

And the build and load the module, that should fix ideapad_wlan always reporting hw-blocked.

This may not be enough / may not be the issue at all though, it could simply be that this laptop is using a wifi chipset for which there is no kernel driver (yet), hmm the inter web says the wifi is intel,
so I guess that you do get a wlan0 network interface? Then this definitely is an rfkill issue...

Regards,

Hans
Comment 4 Kevin Fenzi 2015-10-27 11:15:46 EDT
(In reply to Hans de Goede from comment #3)
> Hi Kevin,
> 
> So you say that BOTH the wireless and the touchpad are not working. Great, I
> wish Lenovo would fix their stuff, rather then rely on us working around
> their issues. Ah well.
> 
> Lets start with getting the wireless fixed, since that is where the
> ideapad_laptop module comes into play I do not think that it has anything to
> do with the touchpad, but you never know. Please file a separate bug for the
> touchpad issue.

Done. Filed 1275718 for that. 

> So first thing to do is run rfkill list, both with the module blacklisted
> and with it loaded. If with it loaded
> the rfkill list says that ideapad_wlan is hw blocked, you've the same issue
> as on the yoga 2.

sadly rfkill isn't on the live media, so after booting with it blacklisted, loading it to get bluetooth working, then unloading it and loading it again:

<without module loaded>
 0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

<with module loaded>
 0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
2: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes

> If this is the case then blacklisting may not be enough (as you are seeing),
> in this case can you build a kernel with a slightly modified
> drivers/platform/x86/ideapad-laptop.c and try that ?
> 
> Before building edit drivers/platform/x86/ideapad-laptop.c, you should find
> this line at or around line 901:
> 
>         priv->has_hw_rfkill_switch = !dmi_check_system(no_hw_rfkill_list);
> 
> Try changing that to:
> 
>         priv->has_hw_rfkill_switch = 0;
> 
> And the build and load the module, that should fix ideapad_wlan always
> reporting hw-blocked.

ok. Should I be able to just build that one module? I'm trying to use live media until I am sure things all work before wiping out windows. ;) 

> This may not be enough / may not be the issue at all though, it could simply
> be that this laptop is using a wifi chipset for which there is no kernel
> driver (yet), hmm the inter web says the wifi is intel,
> so I guess that you do get a wlan0 network interface? Then this definitely
> is an rfkill issue...

I dont see a wlan0 interface. 

lspci says: 

01:00.0 Network Controller: Intel Corporation Wireless 8260 (rev 3a)

and the intel wireless wiki on kernel.org seems to indicate that this device is supported, but indeed, I don't see it bound to any modules. ;(
Comment 5 Kevin Fenzi 2015-10-27 16:13:34 EDT
ok. I modified ideapad_laptop with the priv->has_hw_rfkill_switch = 0; change and it doesn't seem to actually help me any. ;) Things now show they aren't hard blocked, but I still don't see wireless. 

So, as you noted this may be some deeper issue.
Comment 6 Kevin Fenzi 2015-10-27 17:38:12 EDT
ok. Digging a bit it looks like the pci id for this card isn't exactly listed. 

Adding this: 

diff --git a/drivers/net/wireless/iwlwifi/pcie/drv.c b/drivers/net/wireless/iwlwifi/pcie/drv.c
index b0825c4..accd14a 100644
--- a/drivers/net/wireless/iwlwifi/pcie/drv.c
+++ b/drivers/net/wireless/iwlwifi/pcie/drv.c
@@ -445,6 +445,7 @@ static const struct pci_device_id iwl_hw_card_ids[] = {
        {IWL_PCI_DEVICE(0x24F3, 0x0910, iwl8260_2ac_cfg)},
        {IWL_PCI_DEVICE(0x24F3, 0x0850, iwl8260_2ac_cfg)},
        {IWL_PCI_DEVICE(0x24F3, 0x0950, iwl8260_2ac_cfg)},
+       {IWL_PCI_DEVICE(0x24F3, 0x1130, iwl8260_2ac_cfg)},
 #endif /* CONFIG_IWLMVM */
 
        {0}

Gets it working with the ideapad_laptop change (without that it says it's hard blocked and won't let me enable it). 

Note that 0x24F4 / 0x1130 is listed.
Comment 7 Josh Boyer 2015-10-27 20:34:19 EDT
Nice find.  I looked in the linux-next tree and didn't see it there either.  I'll try and write up a patch to add that PCI ID tomorrow unless Emmanuel has one queued somewhere.
Comment 8 Emmanuel Grumbach 2015-10-28 02:23:30 EDT
Thanks...
I will check internally and submit a patch ASAP.
Note that the timing is bad, I have sent my last pull request to -next on Sunday.
I can a push a patch to iwlwifi-next, but it will take a while until it reaches wireless-drivers-next.git.

Feel free to assign this issue to linuxwifi@intel.com which is really the address you want to CC / Assign for those matters.
Comment 9 Emmanuel Grumbach 2015-10-28 08:09:44 EDT
Fix is here.

https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-fixes.git/commit/?id=35069d255591dad72c2197ccc8c536fc5a9f294f

You can cherry-pick until I push upstream...
Comment 10 Josh Boyer 2015-10-28 08:43:27 EDT
Excellent.  Thanks for the quick reply!
Comment 11 Hans de Goede 2015-10-29 04:26:07 EDT
Hi All,

Thanks for all the work on this while I was enjoying a day of PTO :)

So it seems that we really have 3 bugs here, 2 separate wifi bugs and the touchpad bug ...

Since the missing pci-id bug is mostly fixed now, lets keep this bug for tracking the ideapad_laptop issue.

Kevin can you do:

grep '.*' /sys/class/dmi/id/*_* 2> /dev/null > dmi.log

And attach the generated dmi.log here ? Then I'll whip up a patch adding a dmi-quirk and ask you to test that. Note that log file may contain your laptop's serial number, so you may want to edit that out if you don't want that public.

Regards,

Hans
Comment 12 Emmanuel Grumbach 2015-10-29 05:48:47 EDT
removing Intel Wireless folks.
Comment 13 Kevin Fenzi 2015-10-30 14:24:15 EDT
dmi.log: 

/sys/class/dmi/id/bios_date:10/14/2015
/sys/class/dmi/id/bios_vendor:LENOVO
/sys/class/dmi/id/bios_version:C6CN32WW
/sys/class/dmi/id/board_asset_tag:NO Asset Tag
/sys/class/dmi/id/board_name:VIUU4
/sys/class/dmi/id/board_serial:redacted
/sys/class/dmi/id/board_vendor:LENOVO
/sys/class/dmi/id/board_version:SDK0K45914 WIN
/sys/class/dmi/id/chassis_asset_tag:NO Asset Tag
/sys/class/dmi/id/chassis_serial:redacted
/sys/class/dmi/id/chassis_type:10
/sys/class/dmi/id/chassis_vendor:LENOVO
/sys/class/dmi/id/chassis_version:Lenovo YOGA 900-13ISK
/sys/class/dmi/id/product_name:80MK
/sys/class/dmi/id/product_serial:redacted
/sys/class/dmi/id/product_uuid:redacted
/sys/class/dmi/id/product_version:Lenovo YOGA 900-13ISK
/sys/class/dmi/id/sys_vendor:LENOVO
Comment 14 Hans de Goede 2015-11-06 07:50 EST
Created attachment 1090651 [details]
[PATCH] ideapad-laptop: Add Lenovo Yoga 900 to no_hw_rfkill dmi list

Hi,

(In reply to Kevin Fenzi from comment #13)
> dmi.log: 

Thanks, I'm attaching a patch for ideapad-laptop, as well as an ideapad-laptop.c with the change in question. Can you try one of the 2 and let me know if it fixes things?

Regards,

Hans
Comment 15 Hans de Goede 2015-11-06 07:51 EST
Created attachment 1090652 [details]
ideapad-laptop.c
Comment 16 Kevin Fenzi 2015-11-06 14:36:42 EST
Yep. Works fine here. Thanks!
Comment 17 Hans de Goede 2015-11-09 11:10:16 EST
Hi,

(In reply to Kevin Fenzi from comment #16)
> Yep. Works fine here. Thanks!

Thanks, patch send upstream.

Josh, can you also add the attached ideapad-laptop patch to the Fedora kernels for now (should trickle down through stable soon-ish).

Regards,

Hans
Comment 18 Josh Boyer 2015-11-10 11:33:03 EST
Added to all branches.  Thanks!
Comment 19 Yogesh Sharma 2015-11-19 22:52:24 EST
When they will be hitting FC23 updates or rawhide ?
Comment 20 Josh Boyer 2015-11-20 07:50:25 EST
It's already in rawhide.  F23 will be updated when 4.2.7 is released, or sooner if we need to do another build before then.
Comment 21 Yogesh Sharma 2015-11-23 01:01:26 EST
Hi Kevin

Which Patch fixes touchpad issue ?

Thanks
Comment 22 Kevin Fenzi 2015-11-23 12:05:06 EST
See: https://bugzilla.redhat.com/show_bug.cgi?id=1275718#c7
Comment 23 Fedora Update System 2015-11-25 10:17:41 EST
kernel-4.2.6-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-f26dec73e9
Comment 24 Fedora Update System 2015-11-25 10:19:24 EST
kernel-4.2.6-201.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-912d8e4998
Comment 25 Yogesh Sharma 2015-11-25 18:09:06 EST
I have downloaded kernel-4.2.6-301.fc23, core, modues fro, koji but Wireless issue is not fixed.

Rawhide kernel works for me.
Comment 26 Fedora Update System 2015-11-25 21:24:34 EST
kernel-4.2.6-201.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-912d8e4998
Comment 27 Fedora Update System 2015-11-25 21:53:22 EST
kernel-4.2.6-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-f26dec73e9
Comment 28 nadersalehi1 2015-11-26 13:05:42 EST
Any chance
Comment 29 nadersalehi1 2015-11-26 13:09:16 EST
(In reply to nadersalehi1 from comment #28)
> Any chance

Sorry for the premature save.  Please ignore the comment.
Comment 30 Fedora Update System 2015-11-26 15:54:45 EST
kernel-4.2.6-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 31 Yogesh Sharma 2015-11-27 11:22:14 EST
Still same issue, wireless not working.

Rawhide kernel-core-4.2.6-301.fc23.x86_64 works.
Comment 32 nadersalehi1 2015-11-27 17:53:01 EST
I concur.  I'm currently using kernel-4.4.0-0.rc2.git2.2.fc24.x86_64.  Wireless works fine there.  Touchpad is still to be corrected, but at least I could use a bluetooth mouse to remedy the situation.
Comment 33 Fedora Update System 2015-11-30 18:21:14 EST
kernel-4.2.6-201.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 34 A Boyle 2015-12-01 12:49:57 EST
The ideapad-laptop patch to unblock the hardware is in kernel-4.2.6-301.fc23, however the PCI ids patch is not. I was able to get the wireless working by manually fixing and building the iwlwifi module, using the stable release source.
Comment 35 Yogesh Sharma 2015-12-02 11:22:23 EST
Any plans to get PCI ids patch in and get new rpm out ?
Comment 36 Josh Boyer 2015-12-02 14:34:18 EST
(In reply to Yogesh Sharma from comment #35)
> Any plans to get PCI ids patch in and get new rpm out ?

Hm.  I suppose we should do that, yes.  Not sure how we missed that to be honest.  It's already in our branch tracking 4.3 so we seem to have just missed it for the 4.2 based kernels.
Comment 37 Alphakarem 2015-12-02 15:15:28 EST
So, this should take care of Touchpad, Touchscreen and wireless on the latest stable 4.2 kernel ?

I have been struggling with this for about a week and I seem to not have the best of luck, the best I could get is wireless working from Kernel 4.4.0 rc2.
Comment 38 Josh Boyer 2015-12-02 15:27:40 EST
No, it only should fix wireless.
Comment 39 Alphakarem 2015-12-02 15:56:11 EST
any chance we can get touchpad and touchscreen working as well ? seems like there is a bug https://bugzilla.redhat.com/show_bug.cgi?id=1275718#c11 where there seems to be a fix but as I asked there on that thread doesn't seem to work for me for some reason, is there a way we can have a standard module included as a temp solution until full development is complete ? or a simple guide to help us get it working until proper support is available ?
Comment 40 Fedora Update System 2015-12-10 09:44:21 EST
kernel-4.2.7-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ac9a19888e
Comment 41 Fedora Update System 2015-12-10 09:45:35 EST
kernel-4.2.7-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c4ed00a68f
Comment 42 Fedora Update System 2015-12-11 01:00:38 EST
kernel-4.2.7-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ac9a19888e
Comment 43 Fedora Update System 2015-12-11 14:57:12 EST
kernel-4.2.7-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c4ed00a68f
Comment 44 Yogesh Sharma 2015-12-11 21:20:53 EST
This kernel works as expected, wireless working.
Compare to rawhide kernel, this kernel is not able to control brightness.
Comment 45 Fedora Update System 2015-12-16 03:24:15 EST
kernel-4.2.7-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 46 Fedora Update System 2015-12-16 04:51:11 EST
kernel-4.2.7-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 47 Fedora Update System 2015-12-16 09:35:19 EST
kernel-4.2.7-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.