Bug 1275511 - Samba: Winbind fails to start in a CTDB environment with error accessing the RO database and AVC's.
Samba: Winbind fails to start in a CTDB environment with error accessing the ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: rhs-smb@redhat.com
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 02:56 EDT by surabhi
Modified: 2015-11-19 07:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:55:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 11577 None None None Never

  None (edit)
Description surabhi 2015-10-27 02:56:50 EDT
Description of problem:
In and AD setup with clustering enabled(CTDB) , when the winbind service is stopped and started again, it fails to start winbind. The ctdb logs shows :

2015/10/26 09:12:44.665853 [10292]: Failed to open/create the tracking database '/var/lib/ctdb/netlogon_creds_cli.tdb.1.RO'

  CTDB_CONTROL_SET_DB_READONLY failed: NT_STATUS_OK, -1
[2015/10/26 09:17:48.467939,  0] ../source3/lib/dbwrap/dbwrap_open.c:140(db_open)
  failed to attach to ctdb netlogon_creds_cli.tdb
[2015/10/26 09:17:48.469069,  0] ../source3/auth/auth_domain.c:265(domain_client_va
lidate)
  domain_client_validate: Domain password server not available.
[2015/10/26 09:17:48.469157,  5] ../source3/auth/auth.c:252(auth_check_ntlm_passwor
d)
  check_ntlm_password: winbind authentication for user [root] FAILED with error NT_
STATUS_NO_MEMORY
[2015/10/26 09:17:48.469184,  2] ../source3/auth/auth.c:315(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [root] -> [root] FAILED with error 
NT_STATUS_NO_MEMORY

*****************************************

I see following AVC's as well in audit logs:
type=AVC msg=audit(10/26/2015 13:12:47.949:2270) : avc:  denied  { dac_override } for  pid=12237 comm=ctdbd capability=dac_override  scontext=system_u:system_r:ctdbd_t:s0 tcontext=system_u:system_r:ctdbd_t:s0 tclass=capability 

*********************************************

When the file /var/lib/ctdb/netlogon_creds_cli.tdb.1.RO is moved out from the directory and start winbind, it succeeds. Again if we stop and start winbind it fails to start with the same error.



Version-Release number of selected component (if applicable):
samba-4.2.4-4.el7rhgs.x86_64
ctdb-4.2.4-4.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Do Active directory integration with samba.
2.Do a CTDB setup
3.Start winbind to perform ACL tests from windows
4.Stop winbind and ctdb services and start again

Actual results:
The winbind service fails to start with the error.

Expected results:
The winbind service should start successfully.

Additional info:

Sosreports will be attached soon.
Comment 4 surabhi 2015-11-13 06:14:00 EST
With CTDB ctdb-4.2.4-6.el7rhgs.x86_64 , Stopping and starting winbind/ctdb service happens successfully.
Marking the BZ verified.
Comment 6 errata-xmlrpc 2015-11-19 07:55:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2467.html

Note You need to log in before you can comment on or make changes to this bug.