This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275516 - [platformmanagement_public_460] Got "cannot unmarshal object into Go value of type string" when create jobs
[platformmanagement_public_460] Got "cannot unmarshal object into Go value of...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Maciej Szulik
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 03:00 EDT by weiwei jiang
Modified: 2016-10-30 18:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:14:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description weiwei jiang 2015-10-27 03:00:07 EDT
Description of problem:
When try to create jobs with https://raw.githubusercontent.com/kubernetes/kubernetes/master/docs/user-guide/job.yaml , got "cannot unmarshal object into Go value of type string" error message

# oc create -f job.yaml --v=8
I1027 05:27:53.958501   19854 debugging.go:99] GET https://localhost:8443/oapi
I1027 05:27:53.958552   19854 debugging.go:106] Request Headers:
I1027 05:27:53.958562   19854 debugging.go:109]     User-Agent: oc/v1.0.6 (linux/amd64) openshift/814c05e
I1027 05:27:53.958570   19854 debugging.go:109]     Authorization: Bearer h3QYg2z_C9zuTo0hdbhx_PaHoT--K0OHhMZaYYFFi5Q
I1027 05:27:53.975195   19854 debugging.go:124] Response Status: 200 OK in 16 milliseconds
I1027 05:27:53.975209   19854 debugging.go:127] Response Headers:
I1027 05:27:53.975215   19854 debugging.go:130]     Cache-Control: no-store
I1027 05:27:53.975220   19854 debugging.go:130]     Content-Type: application/json
I1027 05:27:53.975225   19854 debugging.go:130]     Date: Tue, 27 Oct 2015 05:27:53 GMT
I1027 05:27:53.975229   19854 debugging.go:130]     Content-Length: 32
I1027 05:27:53.975247   19854 request.go:777] Response Body: {
  "versions": [
    "v1"
  ]
}
I1027 05:27:53.975494   19854 decoder.go:144] decoding stream as YAML
F1027 05:27:53.975959   19854 helpers.go:96] unable to load "job.yaml": json: cannot unmarshal object into Go value of type string

Version-Release number of selected component (if applicable):
devenv-fedora_2567

How reproducible:
always

Steps to Reproduce:
1. wget https://raw.githubusercontent.com/kubernetes/kubernetes/master/docs/user-guide/job.yaml
2. oc create -f job.yaml
3.

Actual results:
Got message "cannot unmarshal object into Go value of type string
"

Expected results:
It should create successfully with any error messages.

Additional info:
Comment 1 Maciej Szulik 2015-10-30 08:16:28 EDT
This requires https://github.com/openshift/origin/pull/5490 to be merged, since it's using generalized label selector which is part of aforementioned PR.
Comment 2 weiwei jiang 2015-11-01 22:10:35 EST
Checked with devenv_rhel7_2619, and this issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.