Bug 1275524 - Data Tiering:heat counters not getting reset and also internal ops seem to be heating the files
Data Tiering:heat counters not getting reset and also internal ops seem to be...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
: ZStream
: 1276943 (view as bug list)
Depends On: 1272450 1272452 1275483 1276943
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 03:28 EDT by Joseph Elwin Fernandes
Modified: 2016-06-16 09:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275483
Environment:
Last Closed: 2016-06-16 09:41:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-27 03:28:55 EDT
REVIEW: http://review.gluster.org/12433 (tier/dht: Ignore file migration if src is linkto) posted (#1) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2015-10-27 04:55:21 EDT
REVIEW: http://review.gluster.org/12433 (tier/dht: Ignore file migration if src is linkto) posted (#2) for review on master by Joseph Fernandes
Comment 3 Vijay Bellur 2015-10-29 10:54:15 EDT
REVIEW: http://review.gluster.org/12433 (tier/dht: Ignore file migration if src is linkto) posted (#3) for review on master by Joseph Fernandes
Comment 4 Vijay Bellur 2015-11-01 22:25:06 EST
REVIEW: http://review.gluster.org/12480 (cluster/tier correct promotion cycle calculation) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 5 Dan Lambright 2015-11-01 22:26:09 EST
*** Bug 1276943 has been marked as a duplicate of this bug. ***
Comment 6 Vijay Bellur 2015-11-02 07:43:36 EST
REVIEW: http://review.gluster.org/12480 (cluster/tier correct promotion cycle calculation) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 7 Niels de Vos 2016-06-16 09:41:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.