This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 127553 - ncftp 3.1.7-4 sends unexpected FIN while dealing with data socket.
ncftp 3.1.7-4 sends unexpected FIN while dealing with data socket.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ncftp (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Ben Levenson
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-09 13:18 EDT by Valdis Kletnieks
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 08:41:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2004-07-09 13:18:10 EDT
Description of problem:
ncftp fails and sends a FIN when it talks to the data socket.

Version-Release number of selected component (if applicable):
3.1.7-4

How reproducible:
Connect to an FTP server, and issue 'dir' command in non-passive mode

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Ethereal indicates that the PORT command is sent, the 3-packet
handshake takes place, and after the first data packet (containing
a '150 Here comes the directory listing.'), the client end sends
a FIN packet.

Backing off to 3.1.7-2 works.

Ethereal capture is available if needed.
Comment 1 Karsten Hopp 2004-07-09 14:19:28 EDT
Looks like the ipv6 patch is doing something strange here. 
 
Comment 2 Valdis Kletnieks 2004-07-09 14:28:13 EDT
The laptop exhibiting the problem has IPv6 enabled,
but ethereal shows the connection as IPv4.  Could it be a problem
with handling a ::ffff: encapsulated address?
Comment 3 Karsten Hopp 2004-08-09 06:24:12 EDT
I've notified the uptream maintainers of the ipv6 patch of this 
problem and disabled the patch for now. 
Comment 4 Karsten Hopp 2004-08-19 08:41:22 EDT
waiting for a new upstream ipv6 patch 

Note You need to log in before you can comment on or make changes to this bug.