Bug 1275552 - [hosted-engine] Disk actions on Hosted-engine storage domain should warn the user or possible risks.
[hosted-engine] Disk actions on Hosted-engine storage domain should warn the ...
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
x86_64 Unspecified
medium Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Martin Sivák
Elad
: Reopened
: 1431677 (view as bug list)
Depends On:
Blocks: 1444671
  Show dependency treegraph
 
Reported: 2015-10-27 04:41 EDT by Elad
Modified: 2017-05-15 08:26 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1444671 (view as bug list)
Environment:
Last Closed: 2017-05-14 10:21:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)

  None (edit)
Description Elad 2015-10-27 04:41:51 EDT
Description of problem:
3.6 Hosted-engine deployment involves the import of the hosted-engine storage domain. This exposure the HE domain to changes. For example, disks creation on this domain is allowed.

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch
rhevm-3.6.0.2-0.1.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy hosted-engine (hosted-engine deployment supposed to involve the HE SD import on 3.6 late builds. Import the domain manually if it doesn't)
2. Attempt to create disks on the domain


Actual results:
Disks creation is allowed. This can cause to a situation in which the domain space gets filled. 

Expected results:
Operations like disks creation on the hosted-engine storage domain should not be allowed
Comment 1 Martin Sivák 2015-10-29 05:53:33 EDT
I believe this belongs to the ovirt-engine component.
Comment 2 Roy Golan 2016-01-13 04:52:48 EST
Moran I don't want to devel ack that before we understand if we want to block that.
Comment 3 Roy Golan 2016-01-13 08:43:48 EST

*** This bug has been marked as a duplicate of bug 1290478 ***
Comment 4 Elad 2016-01-21 07:48:00 EST
Roy, there are several scenarios that IMO must be blocked or at least raise a warning.

For example:
- Disk creation/copy on/to the HE storage domain
- Storage domain creation out of HE SD LUN (in case it's block storage)
- Storage domain import using HE SD LUN (in case it's block storage)


Anyway, this bug is not a DUP of 1290478 since 1290478 addresses actions on the HE VM and here we are talking about the HE SD.
Comment 5 Moran Goldboim 2016-01-25 07:31:12 EST
(In reply to Roy Golan from comment #2)
> Moran I don't want to devel ack that before we understand if we want to
> block that.

I think that Elad is pointing out the fact that the HE storage domain is not anyhow limited in the system and as an example you can create regular vm images on top of it. which shouldn't be the case and it should handle only the HE vm images.

Elad, anything i missed?
Comment 6 Roy Golan 2016-02-24 05:32:05 EST
That is a case we may want it to be configurable because it may depend on the size and complexity of your deployment.
Comment 7 Elad 2016-03-06 06:57:26 EST
(In reply to Moran Goldboim from comment #5)
> (In reply to Roy Golan from comment #2)
> > Moran I don't want to devel ack that before we understand if we want to
> > block that.
> 
> I think that Elad is pointing out the fact that the HE storage domain is not
> anyhow limited in the system and as an example you can create regular vm
> images on top of it. which shouldn't be the case and it should handle only
> the HE vm images.
> 
> Elad, anything i missed?

That's exactly my point here
Comment 8 Nikolai Sednev 2016-03-06 07:23:08 EST
HE-SD should not be exposed within the engine as Date domain. Creation of additional disks on HE-SD should not be allowed. Customer can easily create VMs with disks on HE-
sd, which will degrade the HE's overall availability and performance.

Any additionally created disks on HE-SD should be exposed only to HE-VM.
Comment 9 Yaniv Lavi 2016-03-06 07:48:35 EST
(In reply to Nikolai Sednev from comment #8)
> HE-SD should not be exposed within the engine as Date domain. Creation of
> additional disks on HE-SD should not be allowed. Customer can easily create
> VMs with disks on HE-
> sd, which will degrade the HE's overall availability and performance.
> 
> Any additionally created disks on HE-SD should be exposed only to HE-VM.

I don't agree, it's up to customer and we can provide a best practice, but no more than that.
Any reason that running vm on the same storage can cause issues with HA?

> - Storage domain creation out of HE SD LUN (in case it's block storage)

What is the diff from regular SD?

> - Storage domain import using HE SD LUN (in case it's block storage)

What is the diff from regular SD?
Comment 10 Elad 2016-03-06 08:09:38 EST
> > - Storage domain creation out of HE SD LUN (in case it's block storage)
> 
> What is the diff from regular SD?
In 3.6, first DC initialization triggers the hosted-engine storage domain to be imported to this DC. The problem is that this first DC initialization can be done by creating the first data domain out of the hosted-engine storage domain's LUN in case it is block storage (in case of a file storage, an attempt to create a domain on a path that has a domain on it, is blocked on CDA).

> 
> > - Storage domain import using HE SD LUN (in case it's block storage)
> 
> What is the diff from regular SD?
If the first DC is initialized by importing a data domain to the DC, and this domain is the hosted-engine one, the DC won't initialize since the hosted-engine storage domain cannot take master role (https://bugzilla.redhat.com/show_bug.cgi?id=1315074)
Comment 11 Doron Fediuck 2017-03-13 11:25:31 EDT
*** Bug 1431677 has been marked as a duplicate of this bug. ***
Comment 12 Yaniv Lavi 2017-05-14 10:21:41 EDT
We plan to make the HE SD a normal SD in the system, consideration on workloads being used on this SD will be added to the docs.

Note You need to log in before you can comment on or make changes to this bug.