Bug 127560 - enable xprint support
enable xprint support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 14:49 EDT by Rex Dieter
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 16:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2004-07-09 14:49:53 EDT
Please enable xprint in the mozilla build.  When xprint isn't
installed, it's not used, so it's harmless.

If xprint *is* installed, mozilla can use it.

I say this since I just submitted xprint to Fedora Extras, and it
would be nice if the stock mozilla would support it:
http://bugzilla.fedora.us/show_bug.cgi?id=1851
Comment 1 Christopher Blizzard 2004-07-22 16:29:54 EDT
We're not enabling xprint in the red hat builds.
Comment 2 Rex Dieter 2004-07-22 16:35:23 EDT
Why I don't understand is why not?  AFAIK, simply enabling the support
for it (even though xprint isn't installed or used) is harmless.

Does enabling xprint cause world hunger or hurt baby kittens somehow?
Comment 3 Christopher Blizzard 2004-07-22 16:55:35 EDT
Because then we would have to support it long term.  And xprint is not
our long term printing solution.
Comment 4 Rex Dieter 2004-07-22 19:36:37 EDT
IMO, enabling the abililty to use xprint != having to support it.  If
you *shipped* xprint too, that would be one thing...  Further,
long-term solutions/plans aside, xprint is better than anything else
out there (for printing from mozilla anyway) *right now*.  
Comment 5 Christopher Aillon 2004-07-24 13:45:24 EDT
Right now != next release.

For the record, I plan on having libgnomeprint for Mozilla implemented
soon.
Comment 6 Björn Eriksson 2004-08-13 06:26:35 EDT
Why should Xprint not be supported in Fedora? After all, Xprint will
be integrated into the official X11R6 (6.7.1) release from X.org. 

What other solution(s) does Fedora Core 2 have for printing in
applications that are using the standard X libraries for graphics,
without having to write special printing code? IMHO the Xprint server
and C-libraries are excellent for this purpose.

Note You need to log in before you can comment on or make changes to this bug.