Bug 1275629 - Importing an image from glance never finishes
Importing an image from glance never finishes
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity high (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Daniel Erez
Elad
storage
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 07:41 EDT by David Caro
Modified: 2016-02-10 13:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:22:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
eedri: blocker?
eedri: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
import repo image (84.26 KB, text/plain)
2015-11-02 10:54 EST, Daniel Erez
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47984 master MERGED engine : Importing an image from glance never finishes Never
oVirt gerrit 48036 master MERGED core: avoid NPE on add template when balloonEnabled is null Never
oVirt gerrit 48044 ovirt-engine-3.6 MERGED core: avoid NPE on add template when balloonEnabled is null Never
oVirt gerrit 50988 ovirt-engine-3.6 MERGED engine : Importing an image from glance never finishes 2015-12-24 04:17 EST
oVirt gerrit 50992 ovirt-engine-3.6.2 MERGED engine : Importing an image from glance never finishes 2015-12-27 08:59 EST

  None (edit)
Description David Caro 2015-10-27 07:41:51 EDT
Description of problem:
When importing a disk image from glance service, though the image is downloaded it remains locked by the engine

Version-Release number of selected component (if applicable):

[root@ge-ci-network-engine01 ~]# rpm -qa rhevm
rhevm-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
[root@ge-ci-network-engine01 ~]# rpm -qa rhevm\*
rhevm-setup-plugin-ovirt-engine-common-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-backend-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-image-uploader-3.6.0-1.el6ev.noarch
rhevm-sdk-python-3.6.0.3-1.el6ev.noarch
rhevm-lib-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-spice-client-x86-cab-3.6-3.el6.noarch
rhevm-setup-plugin-ovirt-engine-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-extensions-api-impl-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-branding-rhev-3.6.0-1.el6ev.noarch
rhevm-dependencies-3.6.0-1.el6ev.noarch
rhevm-log-collector-3.6.0-1.el6ev.noarch
rhevm-websocket-proxy-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-doc-3.6.0-1.el6eng.noarch
rhevm-spice-client-x86-msi-3.6-3.el6.noarch
rhevm-userportal-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-setup-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-tools-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-iso-uploader-3.6.0-1.el6ev.noarch
rhevm-cli-3.6.0.0-1.el6ev.noarch
rhevm-setup-base-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-restapi-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-spice-client-x64-msi-3.6-3.el6.noarch
rhevm-dbscripts-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-vmconsole-proxy-helper-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-spice-client-x64-cab-3.6-3.el6.noarch
rhevm-setup-plugin-vmconsole-proxy-helper-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-setup-plugin-websocket-proxy-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-webadmin-portal-3.6.1-0.1000.100.57ae86b.master.el6ev.noarch
rhevm-setup-plugins-3.6.0-1.el6ev.noarch
rhevm-sdk-java-3.6.0.3-1.el6ev.noarch
How reproducible:


Steps to Reproduce:
1.Setup a basic engine with a gluster and an nfs domain
2.import one image from the gluster domain to the nfs one
3.

Actual results:
The image remains in locked state


Expected results:
The image gets created, unlocked and ready to be used

Additional info:
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-27 10:38:51 EDT
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 4 David Caro 2015-10-27 10:59:10 EDT
This works on 3.6.0-17 build though, so probably caused by something added in between 3.6.1 and 3.6.0
Comment 5 Daniel Erez 2015-10-27 14:27:58 EDT
Hi David,

Can you please attach relevant engine and vdsm logs.
Comment 8 Yaniv Lavi 2015-10-29 08:53:47 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 9 Eyal Edri 2015-11-01 08:59:36 EST
major blocker to all automation flows, we need a WA or fix asap.
Comment 10 Daniel Erez 2015-11-01 11:14:58 EST
Seems there's some issue with SEAT infrastructure (I've noticed a similar problem with LSM). It seems that 'endSuccessfully()' of 'AbstractSPMAsyncTaskHandler' isn't being invoked. Still investigating the cause.
@Ravi - do you remember a recent change in async tasks or CoCo infra that might lead to it? Perhaps this one: https://gerrit.ovirt.org/#/c/43971 ? Thnaks!
Comment 11 Oved Ourfali 2015-11-02 08:13:43 EST
(In reply to Daniel Erez from comment #10)
> Seems there's some issue with SEAT infrastructure (I've noticed a similar
> problem with LSM). It seems that 'endSuccessfully()' of
> 'AbstractSPMAsyncTaskHandler' isn't being invoked. Still investigating the
> cause.
> @Ravi - do you remember a recent change in async tasks or CoCo infra that
> might lead to it? Perhaps this one: https://gerrit.ovirt.org/#/c/43971 ?
> Thnaks!

This is only merged on master, and not on 3.6 branch.
The bug is open on 3.6, so doesn't seem related.
Comment 12 Daniel Erez 2015-11-02 10:09:35 EST
(In reply to Oved Ourfali from comment #11)
> (In reply to Daniel Erez from comment #10)
> > Seems there's some issue with SEAT infrastructure (I've noticed a similar
> > problem with LSM). It seems that 'endSuccessfully()' of
> > 'AbstractSPMAsyncTaskHandler' isn't being invoked. Still investigating the
> > cause.
> > @Ravi - do you remember a recent change in async tasks or CoCo infra that
> > might lead to it? Perhaps this one: https://gerrit.ovirt.org/#/c/43971 ?
> > Thnaks!
> 
> This is only merged on master, and not on 3.6 branch.
> The bug is open on 3.6, so doesn't seem related.

Yeah, that's was just a guess :) Maybe another recent change?
Comment 13 Ravi Nori 2015-11-02 10:31:17 EST
From the logs I see that the endAction for action type ImportRepoImage threw a DataIntegrityViolationException exception.

ERROR: insert or update on table "vm_device" violates foreign key constraint "fk_vm_device_vm_static"
Comment 14 Daniel Erez 2015-11-02 10:53:54 EST
(In reply to Ravi Nori from comment #13)
> From the logs I see that the endAction for action type ImportRepoImage threw
> a DataIntegrityViolationException exception.
> 
> ERROR: insert or update on table "vm_device" violates foreign key constraint
> "fk_vm_device_vm_static"

That's because the image was imported as a template. It fails without an exception when just importing an image. Attached are new logs.
Comment 15 Daniel Erez 2015-11-02 10:54 EST
Created attachment 1088620 [details]
import repo image
Comment 16 Elad 2015-11-30 05:05:20 EST
Image import from Glance as disk and as template finishes successfully:

2015-11-30 10:04:03,652 INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (org.ovirt.thread.pool-7-thread-16) [10fb0572] CommandAsyncTask::HandleEndActionResult [within thread]: endAction for action type 'ImportRepoImage' succeeded, clearing tasks.


Verified using:
rhevm-3.6.1-0.2.el6.noarch
vdsm-4.17.11-0.el7ev.noarch
Comment 17 Sandro Bonazzola 2015-12-16 07:22:57 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.