Bug 127563 - colorization is mishandled in some applets
colorization is mishandled in some applets
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 15:41 EDT by Zack Cerza
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 10:54:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (306.81 KB, application/x-gzip)
2004-07-09 15:54 EDT, Zack Cerza
no flags Details

  None (edit)
Description Zack Cerza 2004-07-09 15:41:49 EDT
Description of problem:
Some panel applets become unusable when using a fully-opaque solid
color panel, and some will not recover until the panel color is reset
to "None."

Version-Release number of selected component (if applicable):
gnome-applets-2.6.0-8

How reproducible:
Always.

Steps to Reproduce:
1. Open "Panel Properties."
2. In the "Background" tab, choose "Solid color."
3. Move the "Style" slider to "Transparent." The panel should now be
transparent. This is shown in screen shots named '*-1'.
4. Move the slider to "Opaque." As shown in the screenshots named
'*-2', some of the applets become unusable.
5. Move the slider back to "Transparent." As shown in the screenshots
named '*-3', some of the applets recover and some don't.
  
Actual results:
See "Steps to Reproduce"

Expected results:
Panel applets should either gracefully obey color and opacity
settings, or else completely ignore them. Background color and text
color should not be allowed to be the same (or even too close, ideally).

Additional info:
Missing from the "Utility" screenshots are "InputMethod Switcher" and
"System Monitor" which keep making my panel crash... more on that later.
Comment 1 Zack Cerza 2004-07-09 15:54:27 EDT
Created attachment 101766 [details]
screenshots
Comment 2 Mark McLoughlin 2004-07-19 10:54:27 EDT
Yeah, this is a known issue and I think most applets with the problem
have bugs reported against them (we need a bug for each applet). I'm
going to close this UPSTREAM since we'll probably never get around to
fixing each applet. It would be good, though, if you could ensure each
applet with the problem has a bug logged against it in
bugzilla.gnome.org. Thanks ...
Comment 3 Zack Cerza 2004-07-19 11:11:08 EDT
I meant to close this as UPSTREAM myself. I filed this bug on
gnome-panel and gnome-applets, but the one on -applets was closed as a
duplicate. I assume if I file 10 more, they will as well :)

Should I do it anyway?
http://bugzilla.gnome.org/show_bug.cgi?id=147447
Comment 4 Mark McLoughlin 2004-07-19 15:00:31 EDT
This one is still open, though:

http://bugzilla.gnome.org/show_bug.cgi?id=147447

but I'll close that one out as soon as I get a chance to catch up with
my upstream bug mail :-)

For each applet which you know has the problem, I'd first check to see
if the bug has already been logged and if not log it.

Note You need to log in before you can comment on or make changes to this bug.