Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1275644 - ipa-getkeytab: extended.c:177: ldap_parse_extended_result: Assertion `res != ((void *)0)' failed.
Summary: ipa-getkeytab: extended.c:177: ldap_parse_extended_result: Assertion `res != ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: IPA Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-27 12:19 UTC by Stef Walter
Modified: 2016-03-31 20:30 UTC (History)
11 users (show)

Fixed In Version: freeipa-4.3.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-31 20:30:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Stef Walter 2015-10-27 12:19:23 UTC
Description of problem:

The following happens intermittently during Cockpit integration tests:

Okt 27 13:11:54 falcon.thewalter.lan sh[7284]: ipa-getkeytab: extended.c:177: ldap_parse_extended_result: Assertion `res != ((void *)0)' failed.
Okt 27 13:11:54 falcon.thewalter.lan sh[7284]: sh: line 24:  1480 Aborted                 (core dumped) ipa-getkeytab -q -s f0.cockpit.lan -p HTTP/x0.cockpit.lan -k /etc/krb5.keytab

Version-Release number of selected component (if applicable):

freeipa-client-4.2.2-1.fc23.x86_64
freeipa-server-4.1.4-4.fc22.x86_64

How reproducible:

Seems to happen rarely.

Comment 1 Tomas Babej 2016-01-26 16:35:23 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5642

Comment 2 Tomas Babej 2016-01-26 16:38:04 UTC
This seems to be a legitimate issue, caused by the server timing out on the request (not responding sooner than 10s).

Comment 3 Tomas Babej 2016-02-02 16:34:34 UTC
Fixed upstream:

master:
https://fedorahosted.org/freeipa/changeset/d53c2f6b806335507ffd5e78be42471b85a39bbf/

Comment 4 Fedora Update System 2016-03-24 20:47:41 UTC
freeipa-4.3.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f6e2d255aa

Comment 5 Fedora Update System 2016-03-25 20:27:48 UTC
freeipa-4.3.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f6e2d255aa

Comment 6 Fedora Update System 2016-03-31 20:30:38 UTC
freeipa-4.3.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.