Bug 127574 - Incomplete default options for Neomagic 256AV
Incomplete default options for Neomagic 256AV
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 16:27 EDT by Joachim Frieben
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Neomagic 256AV 1280x1024 screenshot at 16 bpp without "ShadowFB" option. (118.25 KB, image/jpeg)
2004-07-09 16:52 EDT, Joachim Frieben
no flags Details
Neomagic 256AV 1280x1024 screenshot at 16 bpp without "ShadowFB" option. (56.32 KB, image/png)
2005-02-13 10:32 EST, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2627 None None None Never

  None (edit)
Description Joachim Frieben 2004-07-09 16:27:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
For an external 1280x1024 TFT display connected to an IBM Thinkpad
600e, the image gets corrupted when the default "xorg.conf" file based
upon the corresponding entry in "/usr/share/hwdata/Cards" is used.
Parts of the screen are spuriously "mirrored" in the upper part of the
desktop (see attached screenshot).

Version-Release number of selected component (if applicable):
hwdata-0.120-1

How reproducible:
Always

Steps to Reproduce:
1. Start X,
2. Watch spurious ghost images appear while moving windows around, etc.


Actual Results:  The display gets increasingly corrupted as time goes
by after starting an X session.

Expected Results:  No image corruption should occur.

Additional info:

The problem is apparently due to using the entire video memory of 2560
KB when operating at 1280x1024 pixels and 16 bpp. Normal operation can
be restored by enabling the "ShadowFB" option.
Comment 1 Joachim Frieben 2004-07-09 16:52:53 EDT
Created attachment 101772 [details]
Neomagic 256AV 1280x1024 screenshot at 16 bpp without "ShadowFB" option.
Comment 2 Bill Nottingham 2004-09-17 17:40:03 EDT
Unfortunately, this isn't the default case, and I believe that
enabling it will cause a performance hit on other uses. Assigning to X
maintainers for clarification.
Comment 3 Mike A. Harris 2004-09-19 06:30:08 EDT
Using ShadowFB by default will pay a huge performance penalty to
all users.  The proper solution is to fix the driver, which
requires someone familiar with the hardware, access to the hardware,
and specifications to investigate the problem. Unfortunately,
we do not have any of the 3.

Please file a bug report with X.Org, in the freedesktop bugzilla
against the "xorg" component, and hopefully someone on the X.Org
development team has this hardware and the specifications, and can
investigate the issue.

http://bugs.freedesktop.org in the "xorg" component.

Once you've filed a bug report there, please paste the URL here,
and we will track the issue in the upstream bugzilla.  If a fix
or change becomes available in X.Org CVS, we may consider
backporting it to current releases as well.

Thanks in advance.
Comment 4 Mike A. Harris 2004-09-26 17:41:42 EDT
Once this issue is filed in X.Org bugzilla, if someone pastes
the X.Org bug URL here, we will track this issue.  I'm setting
the status of this to "WONTFIX" for now, as there doesn't appear
to be a bug report at X.Org yet for us to track.  If someone
files a bug at X.Org, please reopen this one, and we will track
the X.Org bug.

Thanks in advance.
Comment 5 Joachim Frieben 2004-10-20 02:32:16 EDT
I had postponed an additional bug report to X.org, because a Neomagic
driver update had been announced for version 6.8.0 anyway, so I
decided to wait for the pending new release. I have just installed
FC3T3 plus updates as of October 19, 2004, and I am happy to report
that the submitted bug does not show up anymore. So, at least, the
stock xorg.conf file produced by anaconda needs no further tweaking.
The option "StrangeLockups" is enabled by the driver automatically,
but to the best of my knowledge, this was already the case for the
previous release. The bug should be closed as having been resolved
upstream. Thanks!
Comment 6 Mike A. Harris 2004-10-20 04:13:17 EDT
Ok, thanks for the update.

Setting status to "RAWHIDE".
Comment 7 Joachim Frieben 2005-02-13 10:30:26 EST
It's back: xorg-x11-6.8.2-1.
Comment 8 Joachim Frieben 2005-02-13 10:32:30 EST
Created attachment 111039 [details]
Neomagic 256AV 1280x1024 screenshot at 16 bpp without "ShadowFB" option.
Comment 9 Mike A. Harris 2005-02-16 16:55:55 EST
Please file a bug report with X.Org, in the freedesktop bugzilla
against the "xorg" component, and hopefully someone on the X.Org
development team has this hardware and the specifications, and can
investigate the issue.

http://bugs.freedesktop.org in the "xorg" component.

Once you've filed a bug report there, please paste the URL here,
and we will track the issue in the upstream bugzilla.  If a fix
or change becomes available in X.Org CVS, we may consider
backporting it to current releases as well.

Thanks in advance.


Comment 10 Mike A. Harris 2005-02-16 16:56:36 EST
Setting status to "NEEDINFO", awaiting the X.Org bug URL for tracking.
Comment 11 Joachim Frieben 2005-02-28 07:47:34 EST
Filed bug report with X.org (#2627):

https://bugs.freedesktop.org/show_bug.cgi?id=2627
Comment 12 Mike A. Harris 2005-04-15 10:45:33 EDT
Thanks, tracking in X.Org bugzilla now.

Setting status to "UPSTREAM".

Note You need to log in before you can comment on or make changes to this bug.