Bug 1275752 - WLS: cloning repo results in java.lang.RuntimeException
WLS: cloning repo results in java.lang.RuntimeException
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
x86_64 Linux
urgent Severity urgent
: ER5
: 6.2.0
Assigned To: Maciej Swiderski
Pavel Kralik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 12:12 EDT by Pavel Kralik
Modified: 2015-11-10 02:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 02:33:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WLS cloning modal dialog (103.00 KB, image/png)
2015-10-27 12:12 EDT, Pavel Kralik
no flags Details
WLS server log file (479.79 KB, text/plain)
2015-11-06 04:35 EST, Pavel Kralik
no flags Details

  None (edit)
Description Pavel Kralik 2015-10-27 12:12:08 EDT
Created attachment 1086912 [details]
WLS cloning modal dialog

Description of problem:
When clone repo Mortgages to Org Unit Mortgages from URL: https://github.com/pkralik/mortgage-demo.git
it results in modal dialog with java.lang.RuntimeException.

Version-Release number of selected component (if applicable):
BPMS 6.2.0.ER4

How reproducible:
Always

Steps to Reproduce:
1. Create org unit Mortgages
2. Clone to repo Mortgages
3. with Git URL: https://github.com/pkralik/mortgage-demo.git

Actual results:
java.lang.RuntimeException

Expected results:
Successful cloning

Additional info:
Comment 2 Maciej Swiderski 2015-10-28 11:44:31 EDT
just tried on latest build of 6.3.x and I could clone both repository given in description as well as both playground repositories (uf-playground and jbpm-playground). Moving to modified to retest
Comment 3 Pavel Kralik 2015-11-06 04:35:06 EST
Above HTTPS GIT repository cannot be cloned in BPMS 6.2.0.ER5. I am attaching the server log.
Comment 4 Pavel Kralik 2015-11-06 04:35 EST
Created attachment 1090544 [details]
WLS server log file
Comment 5 Maciej Swiderski 2015-11-06 12:42:29 EST
Since I cannot reproduce that there might be something related to the environment and thus might randomly work or not. Since this is a third party application server which would be time consuming to figure out how to resolve it. Moreover it happens when doing git operations via jgit which again is third party and we cannot alter the way it handles https connections.

There is a which that is suppose to solve the problem (though haven't verified myself since I cannot reproduce the original issue) I recommend to try it and if it does solve the problem document it.

Parameter that needs to be set is UseSunHttpHandler=true which is another system property

[1] http://stackoverflow.com/questions/18512009/weblogic-net-http-soaphttpsurlconnection-cannot-be-cast-to-javax-net-ssl-httpsur
Comment 6 Jan Hrcek 2015-11-10 02:33:22 EST
Maciej, 
setting the system property UseSunHttpHandler=true (using JAVA_OPTIONS as described in the above stackoverflow answer) resolved the issue, so that now it's possible to clone the repositories from urls starting with "https://"
I'm closing this bugzilla as NOTABUG and I'll open new, separate bugzilla for documentation.
Thank you
Comment 7 Jan Hrcek 2015-11-10 02:53:23 EST
Documentation Bug #1279741 created.

Note You need to log in before you can comment on or make changes to this bug.