Bug 1275778 - Unable to set VM highly available in Instance type
Unable to set VM highly available in Instance type
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0.2
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Tomas Jelinek
sefi litmanovich
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 13:21 EDT by Vladimir Astafiev
Modified: 2016-04-21 10:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:35:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
tjelinek: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
engine.log messages (1.10 KB, text/plain)
2015-10-27 13:21 EDT, Vladimir Astafiev
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55011 master MERGED webadmin: the HA flag was not shown in the edit instance type 2016-03-22 04:44 EDT
oVirt gerrit 55116 ovirt-engine-3.6 MERGED webadmin: the HA flag was not shown in the edit instance type 2016-03-23 12:17 EDT

  None (edit)
Description Vladimir Astafiev 2015-10-27 13:21:11 EDT
Created attachment 1086945 [details]
engine.log messages

Version-Release number of selected component (if applicable):
   oVirt Engine Version: 3.6.0.2-1.el7.centos

How reproducible:
Always

Steps to Reproduce:
1. Create/Edit Instance Type
2. Set Host -> Allow manual and automatic migration
   Set High Availability -> Highly Available
3. Press OK

Actual results:
VMs created from this instance is not highly available, option in instance is not checked

Expected results:
VMs created from this instance is highly available, option in instance type is checked

Additional info:
I found this problem after upgrade from RC1 to RC3
Comment 1 sefi litmanovich 2016-03-14 07:58:26 EDT
Bug partially reproduced on rhevm-3.6.3.4-0.1.el6.noarch:

1. Created a custom instance and Set Host -> Allow manual and automatic migration
   Set High Availability -> Highly Available (tried with all 3 priorities)
2. Edited the 'small' instance and Set Host -> Allow manual and automatic migration
   Set High Availability -> Highly Available (tried with all 3 priorities)
3. Create a vm from the custom instance.
4. Create a vm from 'small' instance.

Result ->

In both cases the VMs created from the instance was set to Highly available exactly as was defined in the instance so this part is working fine.

The part that does reproduce is that when I edit again the custom and 'small' instances, the Highly available check-box is unchecked, BUT the priority is still set as last time I edited, and even if I don't "re check" the box, and keep it the same, if I create another vm it is marked as highly available.. so my guess is that the only bug here is a GUI bug, since the box should be checked in the edit instance type menu.
Comment 2 sefi litmanovich 2016-04-03 11:50:25 EDT
Can only verify partially. Cannot verify with new instance type flow due to instance type creation bug: https://bugzilla.redhat.com/show_bug.cgi?id=1323493.
Verified with Edit instance type flow.
Let me know if we can verify this or we should wait for next build until the instance type bug is fixed to verify.
Comment 3 sefi litmanovich 2016-04-04 04:44:06 EDT
As the flow is the same once the instance type is created, it makes no real difference if the instance type is new or existing.. so I mark this bz as verified.
This was tested on rhevm-3.6.5-0.1.el6.noarch.

Note You need to log in before you can comment on or make changes to this bug.