Bug 1275801 - SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'getattr' accesses on the file /usr/bin/pulseaudio.
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'getattr' accesses on ...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a2b66c9088d197911a6b404c713...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 14:53 EDT by Heiko Adams
Modified: 2015-11-11 03:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 03:50:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2015-10-27 14:53:51 EDT
Description of problem:
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'getattr' accesses on the file /usr/bin/pulseaudio.

*****  Plugin catchall (100. confidence) suggests   **************************

If sie denken, dass es abrt-hook-ccpp standardmässig erlaubt sein sollte, getattr Zugriff auf pulseaudio file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:pulseaudio_exec_t:s0
Target Objects                /usr/bin/pulseaudio [ file ]
Source                        abrt-hook-ccpp
Source Path                   /usr/libexec/abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-addon-coredump-helper-2.7.0-1.fc23.x86_64
Target RPM Packages           pulseaudio-7.0-1.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-151.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-300.fc23.x86_64 #1 SMP Mon
                              Oct 5 15:42:54 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-10-19 20:58:21 CEST
Last Seen                     2015-10-19 20:58:21 CEST
Local ID                      7d9cf663-e1c9-4c2b-a3a6-e54dee0cd071

Raw Audit Messages
type=AVC msg=audit(1445281101.647:1316): avc:  denied  { getattr } for  pid=6285 comm="abrt-hook-ccpp" path="/usr/bin/pulseaudio" dev="dm-2" ino=532486 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:pulseaudio_exec_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1445281101.647:1316): arch=x86_64 syscall=stat success=no exit=EACCES a0=5652895ee4d0 a1=7ffe072972f0 a2=7ffe072972f0 a3=5652895ee700 items=0 ppid=6117 pid=6285 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-hook-ccpp exe=/usr/libexec/abrt-hook-ccpp subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)

Hash: abrt-hook-ccpp,abrt_dump_oops_t,pulseaudio_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-151.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-11 03:50:51 EST

*** This bug has been marked as a duplicate of bug 1276305 ***

Note You need to log in before you can comment on or make changes to this bug.