Bug 1275836 - Stoping a vm during live merge will cause the snapshot's disk to be in ILLEGAL state
Stoping a vm during live merge will cause the snapshot's disk to be in ILLEGA...
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0.2
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.6
: ---
Assigned To: Ala Hino
Aharon Canan
storage
: Automation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 17:51 EDT by Raz Tamir
Modified: 2016-05-04 04:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-14 04:57:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
engine and vdsm logs (396.08 KB, application/x-bzip)
2015-10-27 17:51 EDT, Raz Tamir
no flags Details
new logs (1.23 MB, application/x-gzip)
2016-04-11 03:36 EDT, Raz Tamir
no flags Details
screenshots (226.76 KB, image/png)
2016-04-11 03:38 EDT, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2015-10-27 17:51:00 EDT
Created attachment 1087060 [details]
engine and vdsm logs

Description of problem:
Live merge will fail if we will stop the vm during the operation (expected result) and the snapshot's disks will mark as ILLEGAL.
The snapshot is unusable - engine.log:
" The following attached disks are in ILLEGAL status: virtio_raw_False_nfs_disk_6058, virtio_cow_True_nfs_disk_6058, live_merge_vm_nfs_Disk_glance_6058, virtio_scsi_raw_False_nfs_disk_6058, virtio_scsi_raw_True_nfs_disk_6058, virtio_raw_True_nfs_disk_6058, virtio_scsi_cow_True_nfs_disk_6058 - please remove them and try again."


Version-Release number of selected component (if applicable):
rhevm-3.6.0.2-0.1.el6.noarch
vdsm-4.17.10-5.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create vm with 4 disks
2. create 3 snapshots
3. remove the second snapshot
4. stop the vm

Actual results:
The snapshot's disk marks as ILLEGAL state

Expected results:


Additional info:
Comment 1 Allon Mureinik 2015-10-28 08:50:37 EDT
Raz, just to clarify - is the DISK marked as illegal or just the SNAPSHOT we we're trying to merge?
If it's the former, this is a nasty bug. If it's the latter, this is by design.
Comment 2 Red Hat Bugzilla Rules Engine 2015-10-28 08:50:43 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Raz Tamir 2015-10-28 10:47:48 EDT
Allon,
I'm talking about the snapshot (disks sub tub of snapshot).
So I guess this this is by design
Comment 4 Raz Tamir 2016-03-30 14:29:26 EDT
Allon,
I just realized, from your last comment, that "this is a nasty bug".
The disks of the vm become ILLEGAL.
Comment 5 Greg Padgett 2016-03-30 14:32:38 EDT
In some cases, the disks becoming illegal is by design as well--but regardless we should take a look to ensure there's nothing surprising going on.
Comment 6 Red Hat Bugzilla Rules Engine 2016-03-30 18:12:58 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Ala Hino 2016-04-11 03:09:14 EDT
Raz,

I tried to reproduce this one but with no success. In all my attempts, the snapshot, as expected, becomes ILLEGAL but the disk remains OK.

Would appreciate if you can try again and maybe provide some more info in order to reproduce.
Comment 8 Raz Tamir 2016-04-11 03:36 EDT
Created attachment 1145842 [details]
new logs

Ala,
I'm attaching new engine and vdsm logs + screenshot.

After the snapshot's disks become ILLEGAL I tried to preview the snapshot and got the error:
Status: 500
Reason: Internal Server Error
Detail: [Cannot preview Snapshot. The following attached disks are in ILLEGAL status: virtio_cow_True_nfs_disk_6058, virtio_raw_True_nfs_disk_6058, virtio_scsi_raw_True_nfs_disk_6058, live_merge_vm_nfs_6058_Disk_0_6058, virtio_scsi_cow_True_nfs_disk_6058 - please remove them and try again.]
Comment 9 Raz Tamir 2016-04-11 03:38 EDT
Created attachment 1145843 [details]
screenshots
Comment 10 Allon Mureinik 2016-04-14 04:57:16 EDT
(In reply to ratamir from comment #8)
> Created attachment 1145842 [details]
> new logs
> 
> Ala,
> I'm attaching new engine and vdsm logs + screenshot.
> 
> After the snapshot's disks become ILLEGAL I tried to preview the snapshot
> and got the error:
> Status: 500
> Reason: Internal Server Error
> Detail: [Cannot preview Snapshot. The following attached disks are in
> ILLEGAL status: virtio_cow_True_nfs_disk_6058,
> virtio_raw_True_nfs_disk_6058, virtio_scsi_raw_True_nfs_disk_6058,
> live_merge_vm_nfs_6058_Disk_0_6058, virtio_scsi_cow_True_nfs_disk_6058 -
> please remove them and try again.]

If a live merge starts and fails the DISK SNAPSHOT should be marked as illegal, as it no longer represents a consistent point in time.
Such a state can't be previewed, which is fine.

There's no bug here.
Comment 11 Ala Hino 2016-05-04 04:18:14 EDT
Resolving needinfo as the required info provided by Allon: https://bugzilla.redhat.com/1275836#c10

Note You need to log in before you can comment on or make changes to this bug.