Bug 1275845 - Add an already exist storage connection to a data center with a storage domain should fail
Add an already exist storage connection to a data center with a storage domai...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.4
: 4.1.4.2
Assigned To: Allon Mureinik
Raz Tamir
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 18:48 EDT by Raz Tamir
Modified: 2017-07-28 10:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 10:18:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+


Attachments (Terms of Use)
print screen (103.89 KB, image/png)
2015-10-27 18:48 EDT, Raz Tamir
no flags Details
engine and vdsm logs (513.94 KB, application/x-bzip)
2015-10-27 18:49 EDT, Raz Tamir
no flags Details

  None (edit)
Description Raz Tamir 2015-10-27 18:48:44 EDT
Created attachment 1087086 [details]
print screen

Description of problem:
When adding an existing storage connection again, it should fail.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Login to all iscsi targets
2. Add new storage domain
3. Add an already existing storage connection

Actual results:
It is possible to add the same connection twice

Expected results:
It shouldn't be allowed to add the same storage connection twice

Additional info:
Comment 1 Raz Tamir 2015-10-27 18:49 EDT
Created attachment 1087087 [details]
engine and vdsm logs
Comment 2 Allon Mureinik 2015-10-28 08:52:26 EDT
I don't understand the flow.
What exactly are you adding, and how are you doing this?
If it's done via REST - please provide the exact requests you're sending.
if it's done via the GUI, please provide screenshots.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-28 08:52:30 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Raz Tamir 2015-10-28 10:57:07 EDT
I'm trying to add a storage connection that located in DB under storage_server_connections table (attached print screen)

The POST request:
https://jenkins-vm-11.scl.lab.tlv.redhat.com/ovirt-engine/api/storageconnections body:
<storage_connection>
    <address>10.35.160.107</address>
    <type>iscsi</type>
    <port>3260</port>
    <target>iqn.1992-04.com.emc:cx.ckm00121000438.b7</target>
</storage_connection>
Comment 5 Yaniv Lavi (Dary) 2017-02-23 06:26:07 EST
Moving out all non blocker\exceptions.
Comment 6 Allon Mureinik 2017-07-24 10:03:19 EDT
When testing with the current master (commit 121657e), I get the expected 409 error when testing this scenario:


<fault>
    <detail>[Cannot add Storage Connection. Storage connection already exists.]</detail>
    <reason>Operation Failed</reason>
</fault>

It seems that the relevant code has been there for a while.
Setting to ON_QA for QA to verify on 4.1.5, but realistically this can even be verified in 4.1.4 if QE have the capacity.
Comment 7 Raz Tamir 2017-07-24 10:41:39 EDT
Thanks Allon,

Verified for both master and 4.1.4.

Note You need to log in before you can comment on or make changes to this bug.