Bug 1275905 - [RFE] colorize log display in webui, command line
[RFE] colorize log display in webui, command line
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Website (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jessica Forrester
Yanping Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 01:54 EDT by Erik M Jacobs
Modified: 2015-10-28 09:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-28 09:35:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik M Jacobs 2015-10-28 01:54:41 EDT
The current webui implementation of the logging view is AWESOME.

I don't know how easy or hard it is right now, but perhaps there is some kind of web plugin that we can use to "colorize" the log. For blogs and showing code you have things like GeSHi (http://qbnz.com/highlighter/) and I'm wondering if maybe something like that would be able to be incorporated some day.

For OpenShift "go" messages we might want to have a syntax highlighting scheme, and this might be usable in the system logs as well (journalctl)...
Comment 2 Jessica Forrester 2015-10-28 09:35:00 EDT
Since this is an RFE and not a bug, moving this to github so we can have a technical discussion on it https://github.com/openshift/origin/issues/5453

Note You need to log in before you can comment on or make changes to this bug.