Bug 1275917 - [New] - Promote and demote files in gluster volume tier <vol_name> status are misleading [NEEDINFO]
[New] - Promote and demote files in gluster volume tier <vol_name> status are...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: hari gowtham
nchilaka
: ZStream
Depends On:
Blocks: 1358580
  Show dependency treegraph
 
Reported: 2015-10-28 02:28 EDT by RamaKasturi
Modified: 2018-02-06 12:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1358580 (view as bug list)
Environment:
Last Closed: 2018-02-06 12:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vagarwal: needinfo? (knarra)


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-10-28 02:28:37 EDT
Description of problem:
Files in a tiered volume gets promoted and demoted based on  how frequently they are accessed and user can see these numbers in gluster volume tier <vol_name> status output.
I see that the numbers in the promoted and demoted files column are growing cumulatively irrespective of actual number of files present in the volume.

I think there should be a reset introduced some where to show the correct number of files which are getting promoted/demoted otherwise it would create confusion to the user as there are always more number of files listed in the gluster volume tier <vol_name> status output than what is actually present in the volume.

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-0.3.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create an EC volume as cold tier and attach distribute replicate as hot tier.
2. Mount the tiered volume using fuse mount and create 50 files.
3. Access some files so that they get promoted.

Actual results:
Though there are only 50 files in the actual volume tier status output shows that there are more number of files than that.

[root@dhcp37-218 ~]# gluster vol tier vol_ec status
Node                 Promoted files       Demoted files        Status              
---------            ---------            ---------            ---------           
localhost            234                  0                    in progress         
10.70.37.113         0                    235                  in progress         
volume rebalance: vol_ec: success: 


Expected results:
Tier status should only show the actual no of files which gets promoted or demoted and files should not be more than actual no of files present in the mount point.

Additional info:
Comment 2 Vivek Agarwal 2015-10-30 14:20:55 EDT
Seems to be difficult, the tiering process is continously running. At what point in time does it reset to zero and then count forward again
Comment 7 Shyamsundar 2018-02-06 12:43:21 EST
Thank you for your bug report.

We are no longer working on any improvements for Tier. This bug will be set to CLOSED WONTFIX to reflect this. Please reopen if the rfe is deemed critical.

Note You need to log in before you can comment on or make changes to this bug.