Bug 127592 - no work around for conflict between initscripts and pppd
no work around for conflict between initscripts and pppd
Status: CLOSED DUPLICATE of bug 127554
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 20:36 EDT by Gavin C. Flower
Modified: 2014-01-21 17:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin C. Flower 2004-07-09 20:36:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
This a live problem, and no work around for Fedora Core 2 has been
mentioned in the related bugs  123680  and  123697.

What is the point of releasing an update to ppp, if we cannot upgrade?

Please provide a work arouind, rather than simply close this as fixed,
duplicate.

I don't see any flag in yum to overide the error and to force the upgrade.


Thanks.

Gavin

Version-Release number of selected component (if applicable):
yum 2.0.7

How reproducible:
Always

Steps to Reproduce:
1.yum update ppp*
2.
3.
    

Actual Results:  # yum update ppp*
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 -- Fedora US mirror
Server: Fedora Linux (stable) for Fedora Core 2 -- Fedora US mirror
retrygrab() failed for:
 
ftp://ftp.tu-chemnitz.de/pub/linux/fedora/2/i386/RPMS.stable/headers/header.info
  Executing failover method
Server: Fedora Core 2 updates -- Fedora US mirror
retrygrab() failed for:
 
ftp://ftp.quicknet.nl/pub/Linux/ftp.fedora.us/2/i386/RPMS.updates/headers/header.info
  Executing failover method
retrygrab() failed for:
 
ftp://ftp.tu-chemnitz.de/pub/linux/fedora/2/i386/RPMS.updates/headers/header.info
  Executing failover method
Server: Livna.org Fedora Compatible Packages (stable)
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
.conflict between initscripts and pppd
#


Expected Results:  ppp upgrade without errors

Additional info:
Comment 1 Paul Iadonisi 2004-07-10 16:12:30 EDT
  From my reading of the bugs referenced here, it doesn't look like a
yum bug at all.  It's looks to be a ppp packaging problem and/or an
rpm bug.  Anyhow, you can override the dependency problem by grabbing
the ppp rpm and installing using 'rpm -i --nodeps' instead of using yum.
  But I would have hoped to see a quicker fix from Red Hat.  I find it
quite maddening that an update was released without a simple upgrade
test on a system dedicated for update testing.  I know some of the rpm
related problems listed in the bugs referenced in this bug are
complex, but it would have been a simple matter to NOT add the
dependency on a non-versioned pppd if it causes problems, at least for
the time being.  IF indeed the dependency on a non-versioned pppd is
even correct.
  Please, remove the bad dep and issue a ppp-2.4.2-3.FC2.2.i386.rpm
update ;-)
Comment 2 Ian Collier 2004-07-10 17:10:11 EDT
In my opinion, however correct the "provides: pppd" line
is in the new ppp package, it should not have been released
on the fc2-updates channel given that it conflicts with the
installed system.  By all means keep it in for future Fedora
versions, but remove the line from the spec file before releasing
it on FC2.
Comment 3 Jeff Johnson 2004-07-10 21:46:16 EDT
This is a ppp, not an rpm, problem. Reassigning ...
Comment 4 Thomas Woerner 2004-07-12 06:13:17 EDT

*** This bug has been marked as a duplicate of 127554 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.